summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrittany Figueroa2022-10-02 01:17:11 -0700
committerBrittany Figueroa2022-10-02 01:17:11 -0700
commitb13ca7e0bb6310d01c80b91e4fc831ed86334d08 (patch)
tree625373fcf94b45684c17ca1d64e2a54e053053dd /PKGBUILD
downloadaur-yj-bin.tar.gz
Initial commit
Signed-off-by: Brittany Figueroa <>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..291d19a08244
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Brittany Figueroa <dormwear underscore iure at crowley dot seership dot dev>
+
+pkgname=yj-bin
+_pkgname="${pkgname%-bin}"
+pkgver=5.1.0
+pkgrel=1
+pkgdesc='CLI to convert between YAML, TOML, JSON, and HCL'
+arch=('x86_64')
+_goos='linux'
+_goarch='amd64'
+url="https://github.com/sclevine/${_pkgname}/releases"
+license=('Apache')
+provides=("${_pkgname}")
+conflicts=(
+ "${_pkgname}"
+ "${_pkgname}-git"
+)
+source=("${_pkgname}-${pkgver}"::"${url}/download/v${pkgver}/${_pkgname}-${_goos}-${_goarch}")
+b2sums=('efa71a2534846069478818d90266e350ae65021bb24661fcc6459cc60a0d81fdd0fe58ac3bf336ba799a6ae73d11405202c066ea54fcdfbb5d106d695bb41adf')
+
+package() {
+ install -D --mode 755 "${_pkgname}-${pkgver}" "${pkgdir}/usr/bin/${_pkgname}"
+}