summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDries0072020-12-02 12:02:18 +0100
committerDries0072020-12-02 12:02:18 +0100
commitd3f70cf291c5770c0df4cfe37ca083e0ec46c3b6 (patch)
treefdf398ac2b3ebece247706303a9a218d657fa8b9 /PKGBUILD
downloadaur-ykush.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70a679d35852
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Dries007 <admin@dries007.net>
+pkgname=ykush
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Yepkit Boards Control Application"
+arch=('any')
+url="https://github.com/Yepkit/ykush"
+license=('Apache')
+depends=(
+ 'libusb'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Yepkit/ykush/archive/${pkgver}.tar.gz")
+sha256sums=('ccdffc34308c24fbf370ee86cec3ae74df4430f5606d447e9a63310bc676aa62')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make ykushcmd
+}
+
+package() {
+ # The provided install script just does a "sudo cp". I think we can do better.
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ install bin/ykushcmd "$pkgdir/usr/bin"
+}