summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTheJackiMonster2020-04-23 01:18:12 +0200
committerTheJackiMonster2020-04-23 01:18:12 +0200
commit2dae8b471be2ef1befeaced6ced2de012b682519 (patch)
tree02a4fae4a87d78119f26b62d1f24cb4d224b53be /PKGBUILD
downloadaur-yml2-hg.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb2e6de95891
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tobias Frisch <thejackimonster@gmail.com>
+
+_pkgname=yml2
+pkgname=$_pkgname-hg
+pkgver=2.6.3
+pkgrel=1
+pkgdesc="A tool written in Python to convert yml to xml"
+arch=('any')
+url='https://pep.foundation/dev/repos/yml2'
+license=('GPL2')
+makedepends=('mercurial' 'python')
+depends=('python-lxml')
+provides=('yml2')
+source=("hg+https://pep.foundation/dev/repos/yml2")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ awk '/^version/ {print $3}' setup.cfg
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+