summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvixfwis2020-11-26 20:04:56 +0300
committervixfwis2020-11-26 20:04:56 +0300
commitb2ac74d53dcaec7e6698d3b33e1c5c6abfc950c0 (patch)
tree010e9c9d0a859f4f884693ac28aa95bc9a922ac4 /PKGBUILD
parent512e584b1f1bdd4002cd32a98253401783034ec6 (diff)
downloadaur-youtube-dlc.tar.gz
adjust according to Arch python package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0882382e684e..f1098ef9a005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ pkgname=youtube-dlc
_gitname=yt-dlc
pkgver=2020.11.11_3
_gitpkgver="2020.11.11-3"
-pkgrel=1
+pkgrel=2
pkgdesc="Fork of youtube-dl - download videos from youtube.com or other video platforms"
arch=('any')
url="https://github.com/blackjack4494/yt-dlc"
license=('custom')
-depends=('python' 'python-setuptools')
-makedepends=('git' 'pandoc' 'zip')
+depends=('python')
+makedepends=('git' 'pandoc' 'python-setuptools')
optdepends=('ffmpeg: for video post-processing'
'rtmpdump: for rtmp streams support'
'atomicparsley: for embedding thumbnails into m4a files'
@@ -26,11 +26,19 @@ prepare() {
build() {
cd ${_gitname}-${_gitpkgver}
- make PREFIX="${pkgdir}/usr"
+ make PREFIX="${pkgdir}/usr" README.txt youtube-dlc.1 bash-completion zsh-completion fish-completion
+ export PYTHONHASHSEED=0
+ python setup.py build
}
package() {
cd ${_gitname}-${_gitpkgver}
- make install PREFIX="${pkgdir}/usr"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ # Completions fix
+ mv "${pkgdir}/usr/share/bash-completion/completions/youtube-dlc"{.bash-completion,}
+ install -Dm644 youtube-dlc.zsh "${pkgdir}/usr/share/zsh/site-functions/_youtube-dlc"
+
+ # License
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}