summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaHIY2022-03-21 12:12:38 +0800
committerJaHIY2022-03-21 12:12:38 +0800
commite87869c82d6335d715c4c3ddcf2ff24de65f078d (patch)
treea72fce9d0b318cbef9cb41fe5c9afdec8f7419dc /PKGBUILD
downloadaur-ysabeau-git.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5582e9609d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kars Wang <jaklsy+aur at gmail dot com>
+
+_gitname=Ysabeau
+pkgbase=ysabeau-git
+pkgname=("otf-${pkgbase}" "ttf-${pkgbase}")
+pkgver=0.003.r107.gc620c84
+pkgrel=1
+pkgdesc="The essence of Garamond in an open-source sans-serif typeface."
+url='https://github.com/CatharsisFonts/Ysabeau'
+arch=('any')
+license=('OFL-1.1 License')
+makedepends=('git')
+provides=("otf-ysabeau=${pkgver}" "ttf-ysabeau=${pkgver}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package_otf-ysabeau-git() {
+ cd "${_gitname}"
+ install -Dm644 fonts/otf/*.otf -t "$pkgdir"/usr/share/fonts/OTF
+}
+
+package_ttf-ysabeau-git() {
+ cd "${_gitname}"
+ install -Dm644 fonts/ttf/*.ttf -t "$pkgdir"/usr/share/fonts/TTF
+}