summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Stalder2023-12-21 10:13:21 +0100
committerNicolas Stalder2023-12-21 10:13:26 +0100
commit88da29e2bdbbf5f2b904f5c6aeae0e8ecd7aff38 (patch)
treec0da0deb3b5e49e0e5a5f846eca8033c459a6398 /PKGBUILD
parentfceac84ab3b7d31ecf61fcf2e412647362673db6 (diff)
downloadaur-yubihsm2-sdk.tar.gz
:bookmark: yubihsm2-sdk 2023.11-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 577e8be35b17..1e04636c9494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nicolas Stalder <n+archlinux@stalder.io>
pkgname=yubihsm2-sdk
-pkgver=2023.01
+pkgver=2023.11
pkgrel=1
pkgdesc="YubiHSM2 SDK"
url="https://developers.yubico.com/YubiHSM2/Releases/"
@@ -12,12 +12,12 @@ license=(Apache "custom:https://www.yubico.com/support/terms-conditions/yubico-l
depends=(bind curl libusb)
source=(
- "https://developers.yubico.com/YubiHSM2/Releases/yubihsm2-sdk-2023-01-fedora37-amd64.tar.gz"
+ "https://developers.yubico.com/YubiHSM2/Releases/yubihsm2-sdk-2023-11-fedora38-amd64.tar.gz"
"70-yubihsm2.rules"
"yubihsm-connector.service"
"yubihsm-connector.yaml"
)
-sha256sums=('3b2b4cd879bc2dc0b37c4243666aeb9055007dcedf10d4421ee6573349fa929e'
+sha256sums=('c78d75473c0d5c3b292d9ed532afb2972fe4ef327345b746859507b1ee557c5b'
'ecd8ad2475463759ae8aa261542856f7f00428a7759252c4b435f5e6775d5cd0'
'3f2e731277d0fbdda8fe7fbff1e04eaf8d2ea40e5ea2b8db7d882f4a5af463b2'
'6f5415db4913d31c0bc6dc398f89e93308251a6f86d07354dc16f062b8e726e0')
@@ -26,16 +26,16 @@ prepare() {
cd $srcdir
mkdir -p yubihsm-connector
- bsdtar -xf yubihsm2-sdk/yubihsm-connector-3.0.4-1.fc37.x86_64.rpm -C yubihsm-connector
+ bsdtar -xf yubihsm2-sdk/yubihsm-connector-3.0.4-1.fc38.x86_64.rpm -C yubihsm-connector
mkdir -p yubihsm-devel
- bsdtar -xf yubihsm2-sdk/yubihsm-devel-2.4.0-1.fc37.x86_64.rpm -C yubihsm-devel
+ bsdtar -xf yubihsm2-sdk/yubihsm-devel-2.4.2-1.fc38.x86_64.rpm -C yubihsm-devel
mkdir -p yubihsm-setup
- bsdtar -xf yubihsm2-sdk/yubihsm-setup-2.3.1-1.fc37.x86_64.rpm -C yubihsm-setup
+ bsdtar -xf yubihsm2-sdk/yubihsm-setup-2.3.1-1.fc38.x86_64.rpm -C yubihsm-setup
mkdir -p yubihsm-shell
- bsdtar -xf yubihsm2-sdk/yubihsm-shell-2.4.0-1.fc37.x86_64.rpm -C yubihsm-shell
+ bsdtar -xf yubihsm2-sdk/yubihsm-shell-2.4.2-1.fc38.x86_64.rpm -C yubihsm-shell
}
@@ -59,7 +59,7 @@ package() {
install -Dt "$pkgdir/usr/bin" yubihsm-setup/usr/bin/yubihsm-setup
# yubihsm-shell
- shell_version=2.4.0
+ shell_version=2.4.2
install -Dt "$pkgdir/usr/bin" yubihsm-shell/usr/bin/yubihsm-shell
install -Dt "$pkgdir/usr/bin" yubihsm-shell/usr/bin/yubihsm-wrap
cp -d yubihsm-shell/usr/lib64/libyubihsm_http.so.2 "$pkgdir/usr/lib"