summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrendan Szymanski2022-06-08 13:39:15 -0400
committerBrendan Szymanski2022-06-08 13:39:15 -0400
commita79a23172cb348661d20e9752106629210b4fb0a (patch)
tree90abde69f70be18585dab3c60502b4a0c2eecb14 /PKGBUILD
parente845981ded797a78623f55dec2d4add4ec01a4f4 (diff)
downloadaur-a79a23172cb348661d20e9752106629210b4fb0a.tar.gz
Made clang default compiler, applied patch to workaround constexpr vector issue, use system dependencies
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD37
1 files changed, 28 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5819903c3cd4..cf904c58a0e9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r21376.8037f2eae
+pkgver=r21473.4ae75bec5
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
arch=('i686' 'x86_64')
@@ -15,6 +15,7 @@ depends=('desktop-file-utils'
'fmt'
'glslang'
'libfdk-aac'
+ 'libusb'
'libxkbcommon-x11'
'lz4'
'mbedtls'
@@ -31,11 +32,13 @@ depends=('desktop-file-utils'
'zstd')
makedepends=('boost'
'catch2'
+ 'clang'
'cmake'
'ffmpeg'
'git'
'ninja'
- 'nlohmann-json')
+ 'nlohmann-json'
+ 'robin-map')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/benhoyt/inih.git'
'git+https://github.com/kinetiknz/cubeb.git'
@@ -54,7 +57,8 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
# sirit dependencies
- 'git+https://github.com/KhronosGroup/SPIRV-Headers.git')
+ 'git+https://github.com/KhronosGroup/SPIRV-Headers.git'
+ 'yuzu-gcc12-clang13.patch')
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -71,7 +75,8 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '0c60d6dae4ae6c5f33c944c584a5a7dc')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -102,6 +107,9 @@ prepare() {
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
git submodule update --init
done
+
+ cd "$srcdir/$_pkgname"
+ patch -p1 < ../yuzu-gcc12-clang13.patch
}
build() {
@@ -111,23 +119,34 @@ build() {
rm -rf build
fi
mkdir -p build && cd build
- cmake .. \
+ cmake .. -GNinja \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_COMPILER=clang \
+ -DCMAKE_CXX_COMPILER=clang++ \
-DCMAKE_BUILD_TYPE=Release \
-DYUZU_USE_QT_WEB_ENGINE=ON \
-DYUZU_USE_EXTERNAL_SDL2=OFF \
-DUSE_DISCORD_PRESENCE=ON \
-DENABLE_QT_TRANSLATION=ON \
- -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON
- make
+ -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
+ -DBUILD_REPOSITORY=yuzu-emu/yuzu-mainline \
+ -DBUILD_TAG=${pkgver} \
+ -DTITLE_BAR_FORMAT_IDLE="yuzu | ${pkgver} {}" \
+ -DTITLE_BAR_FORMAT_RUNNING="yuzu | ${pkgver} | {}" \
+ -DDYNARMIC_NO_BUNDLED_ROBIN_MAP=ON \
+ -DYUZU_USE_BUNDLED_OPUS=OFF \
+ -DYUZU_USE_BUNDLED_FFMPEG=OFF \
+ -DYUZU_USE_BUNDLED_LIBUSB=OFF \
+ -DYUZU_USE_BUNDLED_QT=OFF
+ ninja
}
check() {
cd "$srcdir/$_pkgname/build"
- make test
+ ninja test
}
package() {
cd "$srcdir/$_pkgname/build"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" ninja install
}