summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrendan Szymanski2019-06-18 00:36:15 -0400
committerBrendan Szymanski2019-06-18 00:36:15 -0400
commite227be14acfc7e4b761aef58365f00c846c7a1fd (patch)
treeb50ec7033f0efc66e180c228513491c0d52eafb0 /PKGBUILD
parentce46b729be19faca017297f47e4661f907c4cca7 (diff)
downloadaur-e227be14acfc7e4b761aef58365f00c846c7a1fd.tar.gz
Automate submodule updating, provide conflict warnings, add title build information and other fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD111
1 files changed, 43 insertions, 68 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 239620f2364a..be761467acce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,94 +1,69 @@
# Maintainer: Zion Nimchuk <zionnimchuk@gmail.com>
-_pkgbase='yuzu'
-pkgbase="$_pkgbase-git"
-pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r7735.fd9da423
+
+_pkgname='yuzu'
+pkgname="$_pkgname-git"
+pkgver=r11844.c7b5c245e
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/yuzu-emu/yuzu/"
license=('GPL2')
-makedepends=('git' 'cmake' 'sdl2' 'qt5-base' 'shared-mime-info' 'desktop-file-utils' 'python2')
-source=("$_pkgbase::git+https://github.com/yuzu-emu/yuzu"
- 'git+https://github.com/yuzu-emu/ext-boost'
- 'git+https://github.com/philsquared/Catch'
- 'git+https://github.com/MerryMage/dynarmic'
- 'git+https://github.com/herumi/xbyak'
- 'git+https://github.com/fmtlib/fmt'
- 'git+https://github.com/svn2github/inih'
- 'git+https://github.com/yuzu-emu/unicorn'
- 'git+https://github.com/lz4/lz4'
- 'git+https://github.com/ogniK5377/opus'
- 'git+https://github.com/DarkLordZach/mbedtls'
- 'git+https://github.com/kinetiknz/cubeb'
- # cubeb submodule dependencies
- 'git+https://github.com/arsenm/sanitizers-cmake')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+provides=('yuzu' 'yuzu-cmd')
+conflicts=('yuzu-canary-git')
+depends=('shared-mime-info'
+ 'desktop-file-utils'
+ 'sdl2'
+ 'qt5-base'
+ 'qt5-multimedia'
+ 'qt5-tools'
+ 'libxkbcommon-x11')
+makedepends=('git'
+ 'cmake'
+ 'python')
+optdepends=('qt5-wayland: for Wayland support')
+source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu")
+md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgbase"
+ cd "$srcdir/$_pkgname"
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/$_pkgbase"
- mkdir -p build
-
- git submodule init
- git config submodule.boost.url "$srcdir/ext-boost"
- git config submodule.catch.url "$srcdir/Catch"
- git config submodule.dynarmic.url "$srcdir/dynarmic"
- git config submodule.xbyak.url "$srcdir/xbyak"
- git config submodule.fmt.url "$srcdir/fmt"
- git config submodule.inih.url "$srcdir/inih"
- git config submodule.unicorn.url "$srcdir/unicorn"
- git config submodule.opus.url "$srcdir/opus"
- git config submodule.mbedtls.url "$srcdir/mbedtls"
- git config submodule.cubeb.url "$srcdir/cubeb"
- git submodule update
+ cd "$srcdir/$_pkgname"
- cd externals/cubeb
- git config submodule.cmake/sanitizers-cmake.url "$srcdir/sanitizers-cmake"
- git submodule update
+ git submodule init
+ git submodule update --init --recursive
}
build() {
- cd "$srcdir/$_pkgbase/build"
+ # Trick the compiler into thinking we're building from a continuous
+ # integration tool so the build number is correctly shown in the title
+ cd "$srcdir/$_pkgname"
+ export CI=true
+ export TRAVIS=true
+ export TRAVIS_REPO_SLUG=yuzu-emu/yuzu
+ export TRAVIS_TAG=$(git describe --tags)
+
+ mkdir -p build
+ cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_BUILD_TYPE=Release \
+ -DYUZU_USE_BUNDLED_UNICORN=ON \
+ -DYUZU_ENABLE_COMPATIBILITY_REPORTING=ON \
+ -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
+ -DUSE_DISCORD_PRESENCE=ON
make
}
-package_yuzu-git() {
- depends=('sdl2' 'libpng')
-
- install -Dm755 "$srcdir/$_pkgbase/build/bin/yuzu-cmd" "$pkgdir/usr/bin/${_pkgbase}-cmd"
+check() {
+ cd "$srcdir/$_pkgname/build"
+ make test
}
-package_yuzu-qt-git() {
- depends=('qt5-base' 'sdl2' 'shared-mime-info' 'desktop-file-utils')
- optdepends=('libxkbcommon-x11: for X11 support'
- 'qt5-wayland: for Wayland support')
-
- cd "$srcdir/$_pkgbase/build"
-
- # screw cubeb and it's shitty cmake
- mkdir -p "$srcdir/$_pkgbase/include/cubeb"
+package() {
+ cd "$srcdir/$_pkgname/build"
make DESTDIR="$pkgdir/" install
-
- rm "$pkgdir/usr/bin/${_pkgbase}-cmd"
}