summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Czygan2023-04-10 12:18:37 +0200
committerMartin Czygan2023-04-10 12:18:37 +0200
commit10daf4c0dd9027ced67f1e97c0054532b033e6f0 (patch)
tree03c41b9e1e022e6990f0e3fe896e75b640acead9 /PKGBUILD
parent2950fc5f49af20f4b03930ee941e6ef378867403 (diff)
downloadaur-zek-bin.tar.gz
update to 0.1.19
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3dfc4138452..48ba34e36cb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=zek-bin
-pkgver=0.1.17
+pkgver=0.1.19
pkgrel=1
pkgdesc="Generate a Go struct from XML"
arch=('x86_64')
@@ -10,13 +10,11 @@ url='https://github.com/miku/zek'
license=('GPL3')
provides=('zek')
depends=('glibc')
-source=("${pkgname}-${pkgver}.deb::https://github.com/miku/zek/releases/download/v${pkgver}/zek_${pkgver}_amd64.deb")
-sha256sums=('004dd1b389f69bfada8fef1a976dc0808be0094c1c64d67b685073e23d096035')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/miku/zek/releases/download/${pkgver}/zek_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums=('ef4958ba7cb74f972cc4bccab61fd25531e96d77d7aa9262d75861466fca9ce9')
package() {
cd "${srcdir}"
- tar xvf data.tar.xz -C "${pkgdir}"
- cd ${pkgdir}/usr
- mv sbin bin
+ tar xvf ${pkgname}-${pkgver}.tar.gz -C "${pkgdir}/bin"
chmod 755 bin/zek
}