summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2022-03-08 20:57:43 +1100
committerRhinoceros2022-03-08 20:57:43 +1100
commit92ac4c2bd9067eea2db48e1ae218aaf0c3abbd41 (patch)
tree8029e25ac6cef2028531749d1ed7fe854976ad01 /PKGBUILD
parent4e9e9c57f3b6fa29a3bdbfdd9d376f637e1b9dcc (diff)
downloadaur-zsh-manydots-magic.tar.gz
Update to r11-2
* Patch to fix [issue](https://github.com/knu/zsh-manydots-magic/issues/2#issuecomment-1042564240)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5dece66b46f..72e78f96214e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,23 @@
pkgname=zsh-manydots-magic
pkgver=r11
_commit=4372de0718714046f0c7ef87b43fc0a598896af6
-pkgrel=1
+pkgrel=2
pkgdesc="zsh zle tweak for emulating \`...'==\`../..', etc."
arch=('any')
url='https://github.com/knu/zsh-manydots-magic'
license=('custom:BSD 2-clause')
depends=('zsh')
makedepends=('git')
-source=("git+https://github.com/knu/${pkgname%-git}.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://github.com/knu/${pkgname%-git}.git#commit=$_commit"
+ 'https://github.com/twang817/zsh-manydots-magic/commit/6525d31436fd3ea9ca0de877c7dccc5763f41e46.patch')
+sha256sums=('SKIP'
+ 'e7fb525d7774b380a402355c5b3332f8f8761ecad3cd8ad94a22dda21f67c5d1')
+
+prepare() {
+ cd "$pkgname"
+ # Fix https://github.com/knu/zsh-manydots-magic/issues/2#issuecomment-1042564240
+ patch -p1 -i "$srcdir/6525d31436fd3ea9ca0de877c7dccc5763f41e46.patch"
+}
package() {
install -Dm644 ${pkgname%-git}/manydots-magic -t "$pkgdir/usr/share/zsh/functions/Zle"