summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBart Libert2024-04-04 14:17:27 +0200
committerBart Libert2024-04-04 14:17:27 +0200
commitc951459722c59e806bfa6e09719b5fa80564cff6 (patch)
tree40fbe9f898e7aed4458dabc004f6bc73b6e9c104 /PKGBUILD
downloadaur-zsh-sudo.tar.gz
Initial commit
Reason for the non-git version: it updated very frequently because things were changed to oh-my-zsh as a whole, but not this plugin specifically
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fafd08e7156c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Bart Libert <bart plus aur at libert dot email>
+_pkgname=zsh-sudo
+_commit=f8bf8f0029a475831ebfba0799975ede20e08742
+pkgname=zsh-sudo
+pkgver=${_commit:0:7}
+pkgrel=1
+pkgdesc="Easily prefix your current or previous commands with sudo by pressing esc twice"
+arch=(any)
+url="https://github.com/ohmyzsh/ohmyzsh/tree/master/plugins/sudo"
+license=("MIT")
+depends=("zsh")
+makedepends=("git")
+source=(git+https://github.com/ohmyzsh/ohmyzsh.git#commit=$_commit)
+conflicts=('zsh-sudo-git')
+sha256sums=('97e5e3454dca543562b6f5672681892d4f2ebf85a9b1737121acbba46b2088ac')
+
+package() {
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/plugins/sudo/sudo.plugin.zsh" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}