summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHenrique Mayer2022-02-09 17:14:56 -0300
committerHenrique Mayer2022-02-09 17:14:56 -0300
commit9c5af6fc5d9a31d473fac6389f30a3adbebff2db (patch)
treed46f1caecfc6083f34a582acc118d8fa1afba71d /PKGBUILD
downloadaur-zsh-thefuck-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5678c6b4571
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Henrique Mayer <hmayer@gmail.com>
+
+pkgname=zsh-thefuck-git
+pkgver=r6.136b5a2
+pkgrel=2
+pkgdesc="ZSH plugin. Initialize thefuck with cache support"
+arch=("any")
+url="https://github.com/laggardkernel/zsh-thefuck"
+license=('MIT')
+depends=('thefuck' 'zsh')
+makedepends=('git')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("git+https://github.com/laggardkernel/zsh-thefuck.git")
+sha512sums=('SKIP')
+install=".install"
+
+pkgver() {
+ cd "zsh-thefuck/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/zsh-thefuck"
+ install -Dm 755 "init.zsh" "${pkgdir}/usr/share/zsh/plugins/${pkgname}/init.zsh"
+ install -Dm 755 "zsh-thefuck.plugin.zsh" "${pkgdir}/usr/share/zsh/plugins/${pkgname}/zsh-thefuck.plugin.zsh"
+ install -Dm 744 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+