summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMateusz Galazyn2021-01-12 09:21:55 +0100
committerMateusz Galazyn2021-01-12 09:21:55 +0100
commitfc4c00625cab052e627fc2a3e25e7a57b4f95a2c (patch)
tree43f698170ef6fced721ae575c446e51a95a06202 /PKGBUILD
parent5a378e94d516c57d39629de545b78b0f020d86a4 (diff)
downloadaur-fc4c00625cab052e627fc2a3e25e7a57b4f95a2c.tar.gz
Improve compatibility, test script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57a3cb0b7491..ab578338597e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Mateusz Galazyn <carbolymer at gmail.com>
-pkgrel=1
+pkgrel=2
pkgver=r547.3e06f0a
pkgname=zsh-zim-git
pkgdesc="ZIM - Zsh IMproved"
@@ -16,8 +16,8 @@ source=('git://github.com/zimfw/zimfw.git'
'zshrc')
md5sums=('SKIP'
'SKIP'
- '37cfb43655ba975a492f5a8a0d436b6e'
- 'ccd089796e6c0cf8e3b7170283b5a724')
+ '6e5ffd11ddfc72d74afb105829821f28'
+ '7874908906dbcb5f85bb1ba1d9ab5c00')
options=('!strip')
install='zim.install'
_gitname='zimfw'
@@ -56,14 +56,14 @@ package() {
cp -f $ZIM_TPL_DIR/zimrc $pkgdir/etc/zsh/zimrc
cp -f zshrc "$pkgdir/etc/zsh/zshrc"
- # patch & recompile zwc file with hardcoded paths
- # assume that you're not running makepkg in directory with '+' in its name
+ # patch zwc file with hardcoded paths
patching=('login_init.zsh' 'init.zsh')
for entry in "${patching[@]}"; do
echo "Patching build paths occurrence in: ${entry}"
- sed -i "s+${pkgdir}++g" "${ZIM_HOME}/${entry}"
+ sed -i "s/${pkgdir//\//\\/}//g" "${ZIM_HOME}/${entry}"
done
find ${ZIM_HOME} -iname "*.old" -type f -exec rm -f \{\} \;
+ # files will be recompiled during installation, when zsh will be executed as root
find ${ZIM_HOME} -iname "*.zwc" -type f -exec rm -f \{\} \;
}