summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2020-12-26 07:36:40 +0100
committerYurii Kolesnykov2020-12-26 07:36:40 +0100
commit1d82076f170ac72b09894ee71605092c25d7ba2e (patch)
tree283eaee0e552c17686b4ba90fc7f3d9a9ccbfc57 /PKGBUILD
parent3744baea63a6d3db93d4eaab6ca7198f65e23cd7 (diff)
downloadaur-1d82076f170ac72b09894ee71605092c25d7ba2e.tar.gz
1.14.41
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e91367c683a..abe61b72f7f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,25 @@
# Contributor: Silvio Knizek <knizek@b1-systems.de>
pkgname=zypper
-pkgver=1.14.39
+pkgver=1.14.41
pkgrel=2
pkgdesc="World's most powerful command line package manager"
arch=('x86_64')
url="https://github.com/openSUSE/${pkgname}"
license=('GPL')
depends=(
+ 'augeas'
'libzypp'
- 'libxml2'
+ 'perl'
'procps'
- 'readline'
- 'augeas'
)
makedepends=(
- 'git'
- 'cmake'
- 'ninja'
- 'boost'
'asciidoc'
'asciidoctor'
+ 'boost'
+ 'cmake'
+ 'git'
+ 'ninja'
)
provides=('apt')
conflicts=('apt')
@@ -30,10 +29,8 @@ source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/openSUSE/zypper/archive/${pkgver}.tar.gz"
'make-ZyppCommon-cmake-module-includable.patch'
)
-sha256sums=(
- '6a86eef7dc1b6da5021ae032929e10038b7586f8edf8b2e3aeb40f44ee88927d'
- 'f5cdd85109c58d786f1124fa3cab1c5431a93a8d87a59117eac257c6e4698ae7'
-)
+sha256sums=('386b5a96773dd39f654d4ae0a11db21efb64c0b47c3cb6350658e282fbc06f06'
+ 'f5cdd85109c58d786f1124fa3cab1c5431a93a8d87a59117eac257c6e4698ae7')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -47,7 +44,7 @@ build() {
-G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_BUILD_TYPE=Release \
- -D LIB=/lib \
+ -D LIB=lib \
-D ZYPP_PREFIX=/usr \
cmake --build build