summarylogtreecommitdiffstats
path: root/Set-the-appropriate-SONAME-for-the-library.patch
diff options
context:
space:
mode:
authorAndrew Sun2019-03-29 21:34:31 -0400
committerAndrew Sun2019-03-29 21:34:31 -0400
commitf551dabf6d465cf468c99bf193df496b53144767 (patch)
tree7f013f2c5528b100ddc68e0993859b0280b34cdf /Set-the-appropriate-SONAME-for-the-library.patch
parentf289e0debfa97e9bf8993e9ec5b724217f8f44e4 (diff)
downloadaur-aces-container.tar.gz
aces-container: add patches and fixes
Diffstat (limited to 'Set-the-appropriate-SONAME-for-the-library.patch')
-rw-r--r--Set-the-appropriate-SONAME-for-the-library.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/Set-the-appropriate-SONAME-for-the-library.patch b/Set-the-appropriate-SONAME-for-the-library.patch
new file mode 100644
index 000000000000..9f5f0c670113
--- /dev/null
+++ b/Set-the-appropriate-SONAME-for-the-library.patch
@@ -0,0 +1,30 @@
+From 96683a250492efcc7059c8c234859ce4a89910b7 Mon Sep 17 00:00:00 2001
+From: Nicolas Chauvet <kwizart@gmail.com>
+Date: Wed, 18 Jul 2018 11:16:29 +0200
+Subject: [PATCH 2/2] Set the appropriate SONAME for the library
+
+Signed-off-by: Nicolas Chauvet <kwizart@gmail.com>
+---
+ CMakeLists.txt | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f5fa059..02f1631 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -88,6 +88,12 @@ GENERATE_EXPORT_HEADER( AcesContainer
+ STATIC_DEFINE AcesContainer_BUILT_AS_STATIC
+ )
+
++# Set the build version (VERSION) and the API version (SOVERSION)
++set_target_properties(AcesContainer
++ PROPERTIES
++ VERSION ${AcesContainer_VERSION}
++ SOVERSION ${AcesContainer_MAJOR_VERSION})
++
+ install (TARGETS AcesContainer EXPORT AcesContainerTargets DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ install (FILES
+ aces_errors.h
+--
+2.17.1
+