summarylogtreecommitdiffstats
path: root/add-stubdom-fixes.patch
diff options
context:
space:
mode:
authorSam Mulvey2022-05-16 11:59:36 -0700
committerSam Mulvey2022-05-16 11:59:36 -0700
commitf7971a3dbdd806bfe71366cf6d91a0c0e1ff0c98 (patch)
tree30943b7c3cfeb3648eddccdbbec1238f4ded7593 /add-stubdom-fixes.patch
parent8c88ec2784c97e91dd385acdc0aefd5744fd2da4 (diff)
downloadaur-f7971a3dbdd806bfe71366cf6d91a0c0e1ff0c98.tar.gz
4.16.1-1, GCC12 fixes
Diffstat (limited to 'add-stubdom-fixes.patch')
-rw-r--r--add-stubdom-fixes.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/add-stubdom-fixes.patch b/add-stubdom-fixes.patch
new file mode 100644
index 000000000000..e063bd3e5bfd
--- /dev/null
+++ b/add-stubdom-fixes.patch
@@ -0,0 +1,11 @@
+diff -Naur orig.xen-4.16.1/stubdom/Makefile xen-4.16.1/stubdom/Makefile
+--- orig.xen-4.16.1/stubdom/Makefile 2022-05-16 09:41:38.409898784 -0700
++++ xen-4.16.1/stubdom/Makefile 2022-05-16 09:43:31.891076356 -0700
+@@ -241,6 +241,7 @@
+ patch -d $@ -p1 < vtpm_extern.patch
+ patch -d $@ -p1 < vtpm-microsecond-duration.patch
+ patch -d $@ -p1 < vtpm-command-duration.patch
++ patch -d $@ -p1 < vtpm-gcc12-fixes.patch
+ mkdir $@/build
+ cd $@/build; CC=${CC} $(CMAKE) .. -DCMAKE_C_FLAGS:STRING="-std=c99 -DTPM_NO_EXTERN $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -Wno-declaration-after-statement"
+ touch $@