summarylogtreecommitdiffstats
path: root/atlassian-crucible.install
diff options
context:
space:
mode:
authorSam Whited2015-12-21 13:51:35 -0600
committerSam Whited2015-12-21 13:51:35 -0600
commit1c0b1637243bab5eb7f270100f05d966c6103d7e (patch)
treec2e113d2dc8cc9cb6f2baf375dc6e949759cb299 /atlassian-crucible.install
downloadaur-atlassian-crucible.tar.gz
Initial pass at a crucible PKGBUILD
Diffstat (limited to 'atlassian-crucible.install')
-rw-r--r--atlassian-crucible.install15
1 files changed, 15 insertions, 0 deletions
diff --git a/atlassian-crucible.install b/atlassian-crucible.install
new file mode 100644
index 000000000000..4d5cbd4e991f
--- /dev/null
+++ b/atlassian-crucible.install
@@ -0,0 +1,15 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ systemd-sysusers crucible.conf
+ systemd-tmpfiles --create crucible.conf
+ chown -R crucible:crucible /etc/crucible
+ chmod -R 750 /etc/crucible
+}
+
+pre_remove() {
+ getent passwd crucible &>/dev/null && userdel crucible &> /dev/null
+ getent group crucible &>/dev/null && groupdel crucible &> /dev/null
+}