summarylogtreecommitdiffstats
path: root/belle-sip.patch
diff options
context:
space:
mode:
authorfrealgagu2019-07-20 13:11:22 -0500
committerfrealgagu2019-07-20 13:11:22 -0500
commitad4a6b3b7e7f8d1e55c0ca879757fa6f340d080e (patch)
tree00970df887602edca748af7816d516dbec4907c2 /belle-sip.patch
parenta59972d0778d935110bd4106dd9f5381073e0754 (diff)
downloadaur-linphone-desktop-all-git.tar.gz
Fixing issue with gcc9 in belle-sip module. Adding include(CheckSymbolExists) in CMakeLists.txt in ortp module.
Diffstat (limited to 'belle-sip.patch')
-rw-r--r--belle-sip.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/belle-sip.patch b/belle-sip.patch
new file mode 100644
index 000000000000..3242db7326e0
--- /dev/null
+++ b/belle-sip.patch
@@ -0,0 +1,32 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1a77461..fad0227 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -37,7 +37,7 @@ set(VERSION "${PACKAGE_VERSION}")
+ option(ENABLE_SHARED "Build shared library." YES)
+ option(ENABLE_STATIC "Build static library." YES)
+ option(ENABLE_RTP_MAP_ALWAYS_IN_SDP "Always include rtpmap in SDP." OFF)
+-option(ENABLE_STRICT "Build with strict compile options." YES)
++option(ENABLE_STRICT "Build with strict compile options." NO)
+ option(ENABLE_TUNNEL "Enable tunnel support" OFF)
+ option(ENABLE_TESTS "Enable compilation of tests" ON)
+ option(ENABLE_MDNS "Enable multicast DNS" OFF)
+diff --git a/src/dns.h b/src/dns.h
+index ac390ae..33d99de 100644
+--- a/src/dns.h
++++ b/src/dns.h
+@@ -158,14 +158,6 @@ DNS_PUBLIC int *dns_debug_p(void);
+
+ #define dns_quietinit(...) \
+ DNS_PRAGMA_PUSH DNS_PRAGMA_QUIET __VA_ARGS__ DNS_PRAGMA_POP
+-#elif (__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4
+-#define DNS_PRAGMA_PUSH _Pragma("GCC diagnostic push")
+-#define DNS_PRAGMA_QUIET _Pragma("GCC diagnostic ignored \"-Woverride-init\"")
+-#define DNS_PRAGMA_POP _Pragma("GCC diagnostic pop")
+-
+-/* GCC parses the _Pragma operator less elegantly than clang. */
+-#define dns_quietinit(...) \
+- __extension__ ({ DNS_PRAGMA_PUSH DNS_PRAGMA_QUIET __VA_ARGS__; DNS_PRAGMA_POP })
+ #else
+ #define DNS_PRAGMA_PUSH
+ #define DNS_PRAGMA_QUIET