summarylogtreecommitdiffstats
path: root/brother-hll6250dw.patch
diff options
context:
space:
mode:
authorMio Iwakura2016-11-06 14:16:41 -0600
committerMio Iwakura2016-11-06 14:16:41 -0600
commit38f01574c50bd2a04dd54c85ac71d451be905de1 (patch)
treec5fd776137080e4777fb6ae3c2613b88e896a4ce /brother-hll6250dw.patch
downloadaur-brother-hll6250dw.tar.gz
PKGBUILD, .SRCINFO, and driver patch
Diffstat (limited to 'brother-hll6250dw.patch')
-rw-r--r--brother-hll6250dw.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/brother-hll6250dw.patch b/brother-hll6250dw.patch
new file mode 100644
index 000000000000..32781a002158
--- /dev/null
+++ b/brother-hll6250dw.patch
@@ -0,0 +1,22 @@
+diff --git a/opt/brother/Printers/HLL6250DW/cupswrapper/brother_lpdwrapper_HLL6250DW b/opt/brother/Printers/HLL6250DW/cupswrapper/brother_lpdwrapper_HLL6250DW
+index 8281c15..01acb5d 100755
+--- a/opt/brother/Printers/HLL6250DW/cupswrapper/brother_lpdwrapper_HLL6250DW
++++ b/opt/brother/Printers/HLL6250DW/cupswrapper/brother_lpdwrapper_HLL6250DW
+@@ -53 +53,3 @@ chomp($basedir);
+-$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
++#$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
++my $PRINTER = "HLL6250DW";
++my $basedir = "/usr/share/Brother/Printer/$PRINTER";
+@@ -85 +87 @@ my $PPD = $ENV{PPD};
+-my $PRINTER=$basedir;
++#my $PRINTER=$basedir;
+@@ -92,3 +94,3 @@ if ( @ARGV >= 6 ){
+-$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
+-$PRINTER =~ s/\/cupswrapper//g;
+-$PRINTER =~ s/\///g;
++#$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
++#$PRINTER =~ s/\/cupswrapper//g;
++#$PRINTER =~ s/\///g;
+@@ -807 +809 @@ sub exec_lpdconfig {
+- $lpddir = $basedir."/lpd/";
++ $lpddir = $basedir."/lpd";