summarylogtreecommitdiffstats
path: root/build_installer.sh
diff options
context:
space:
mode:
authorJernuh Zakalwe2020-08-03 12:33:44 +0200
committerJernuh Zakalwe2020-08-03 12:33:44 +0200
commit8a4b90d1d5554e9674b53d0fbfc86648ea46a42a (patch)
tree1945b293ae39920e3c5b704270e80d113aa8c7f2 /build_installer.sh
parentcc288c84bcb87508c5d370f5ffde29297579962c (diff)
downloadaur-8a4b90d1d5554e9674b53d0fbfc86648ea46a42a.tar.gz
Workaround for error message about missing roots.pem removed.
File roots.pem from evelauncher directory removed because better one error message about missing this file on start of evelauncher instead a bunch of error messages about failed connections to this server later. In both setup scripts recurring messages removed.
Diffstat (limited to 'build_installer.sh')
-rwxr-xr-xbuild_installer.sh13
1 files changed, 7 insertions, 6 deletions
diff --git a/build_installer.sh b/build_installer.sh
index b2816b5c0ce8..437c8fad3fcf 100755
--- a/build_installer.sh
+++ b/build_installer.sh
@@ -37,13 +37,14 @@ while read pline ;do
plc=$(expr $plc + 1)
done < PKGBUILD
+if [ ! -x "$(which curl 2>/dev/null)" ] ;then
+ printf "\nError: Curl not found. Curl are needed for downloading makeself build tool."
+ printf "\n\tPlease install curl with your Package Manager.\n"
+ printf "\nLeaving.\n\n"
+ exit 0
+fi
+
if [ ! -f "./makeself-2.4.0.run" ] ;then
- if [ ! -x "$(which curl)" ] ;then
- echo "Curl not found. Curl are needed for downloading makeself build tool."
- echo " Please install curl with your Package Manager."
- printf "\nLeaving.\n\n"
- exit 0
- fi
printf "\nGet makeself...\n\n"
curl -L -O https://github.com/megastep/makeself/releases/download/release-2.4.0/makeself-2.4.0.run
fi