summarylogtreecommitdiffstats
path: root/build_installer.sh
diff options
context:
space:
mode:
authorJernuh Zakalwe2019-10-13 16:04:58 +0200
committerJernuh Zakalwe2019-10-13 16:04:58 +0200
commitc26036e9e92f0404229fe59cc91766c16a5586f5 (patch)
tree97b92f4d72093a345450295a6d4f2e4889fc329d /build_installer.sh
parent7df07f62d05bc7e6148b3c55585388fe76654a29 (diff)
downloadaur-c26036e9e92f0404229fe59cc91766c16a5586f5.tar.gz
Build scripts for small installer added.
Minor changes on build_installer.sh. Minor changes on setup.sh.in.
Diffstat (limited to 'build_installer.sh')
-rwxr-xr-xbuild_installer.sh8
1 files changed, 5 insertions, 3 deletions
diff --git a/build_installer.sh b/build_installer.sh
index 9663c145308b..9e3f9f87972d 100755
--- a/build_installer.sh
+++ b/build_installer.sh
@@ -1,10 +1,10 @@
#!/bin/sh
-# Buildscript for creating the distribution independed installer.
-# Works only in this directory because some dependencies are here located.
-
set -e
+printf "\n\n Buildscript for creating the distribution independed installer\n"
+printf " with all dependencies and optional evelauncher archive included.\n\n"
+
version=$(grep ^pkgver PKGBUILD | cut -d= -f2) || exit 1
release=$(grep ^pkgrel PKGBUILD | cut -d= -f2) || exit 1
arch=$(uname -m)
@@ -82,6 +82,8 @@ if [ -f "../evelauncher-$version.tar.gz" ] ;then
else
echo "skipped, checksum mismatch."
fi
+else
+ printf "\nEVE Launcher archive not found, will be downloaded during the setup process.\n"
fi
printf "\nBuild self-extractable archive evesetup-$version-$release-$arch.run\n\n"