summarylogtreecommitdiffstats
path: root/config.mk
diff options
context:
space:
mode:
authorPlaton Ryzhikov2020-05-18 19:03:53 +0300
committerPlaton Ryzhikov2020-05-18 19:03:53 +0300
commitba91c7fac2212afee578dc1d5340c3334f432662 (patch)
tree01ecfcadcd6fcde8780aad151adb13c2e3be288b /config.mk
parente6b6b49f957c8837ab986d0eefb69691794a7aca (diff)
downloadaur-ba91c7fac2212afee578dc1d5340c3334f432662.tar.gz
use dynamic linking
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/config.mk b/config.mk
new file mode 100644
index 000000000000..b4d405bd9155
--- /dev/null
+++ b/config.mk
@@ -0,0 +1,20 @@
+# nldev metadata
+NAME = nldev
+VERSION = 0.3
+
+# Customize below to fit your system
+
+# paths
+PREFIX = /usr
+MANPREFIX = ${PREFIX}/share/man
+
+# includes and libs
+INCS = -I. -I/usr/include
+
+# flags
+CPPFLAGS = -DVERSION=\"${VERSION}\" -D_DEFAULT_SOURCE -D_GNU_SOURCE
+CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+
+# compiler and linker
+CC = cc
+