summarylogtreecommitdiffstats
path: root/doom3.install
diff options
context:
space:
mode:
authorSlashbunny2009-08-17 20:47:05 -0400
committerSlashbunny2009-08-17 20:47:05 -0400
commita4b91317e441b05bf5823278757d654454187d6e (patch)
tree9970758363611acca0bd45efb572553a5c70c76f /doom3.install
parent3c69e601007539671c553e4002eb061cd5425e77 (diff)
downloadaur-a4b91317e441b05bf5823278757d654454187d6e.tar.gz
Refactored doom3 PKGBUILD, manual install (rather than running iD installer)
Diffstat (limited to 'doom3.install')
-rw-r--r--[-rwxr-xr-x]doom3.install82
1 files changed, 42 insertions, 40 deletions
diff --git a/doom3.install b/doom3.install
index 6bc2d04e42c4..ef9c4d4d248c 100755..100644
--- a/doom3.install
+++ b/doom3.install
@@ -1,48 +1,50 @@
post_install() {
-cat << EOF
-IMPORTANT
-==> In order to use the software, you have to agree to ID Software's license
-==> located in /opt/doom3/License.txt and Punkbuster's license located in
-==> /opt/doom3/pb/PB_EULA.txt
-==> If you don't, please remove this package (pacman -R doom3)
-IMPORTANT2
-==> If You have x86_64 system and nvidia graphics card, You need to install lib32-nvidia-utils package too.
-==> Thanks jarrebylove.
-
-EOF
-
-cat <<-00installInstructions00
-The following files need to be copied from the win32 install CDs
-to your base/ directory ( md5 sums provided below as reference )
-by default, /opt/doom3/base
-
-71b8d37b2444d3d86a36fd61783844fe base/pak000.pk4
-4bc4f3ba04ec2b4f4837be40e840a3c1 base/pak001.pk4
-fa84069e9642ad9aa4b49624150cc345 base/pak002.pk4
-f22d8464997924e4913e467e7d62d5fe base/pak003.pk4
-38561a3c73f93f2e6fd31abf1d4e9102 base/pak004.pk4
-
-If you are also installing the Resurrection of Evil Expansion Pack,
-you need to copy the following file to your d3xp/ directory
-by default, /opt/doom3/d3xp
-
-a883fef0fd10aadeb73d34c462ff865d d3xp/pak000.pk4
-
-Localization is not supported on Linux ( only english ), you should not copy over any of the zpak files.
-
-Start the game with the command: doom3
-Start the dedicated server with the command: doom3-dedicated
-
-If installed, you can start the Expansion Pack directly from the command line with the command: doom3 +set fs_game d3xp
-Or you can select it in the mods menu of the base game.
+ echo "==> "
+ echo "==> IMPORTANT "
+ echo "==> In order to use the software, you have to agree to ID Software's license "
+ echo "==> located in /opt/doom3/License.txt and Punkbuster's license located in "
+ echo "==> /opt/doom3/pb/PB_EULA.txt "
+ echo "==> If you don't, please remove this package (pacman -R doom3) "
+ echo "==> IMPORTANT2 "
+ echo "==> If You have x86_64 system and nvidia graphics card, You need to install lib32-nvidia-utils package too. "
+ echo "==> Thanks jarrebylove. "
+ echo "==> "
+ echo "==> The following files need to be copied from the win32 install CDs "
+ echo "==> to your base/ directory ( md5 sums provided below as reference ) "
+ echo "==> by default, /opt/doom3/base "
+ echo "==> "
+ echo "==> 71b8d37b2444d3d86a36fd61783844fe base/pak000.pk4 "
+ echo "==> 4bc4f3ba04ec2b4f4837be40e840a3c1 base/pak001.pk4 "
+ echo "==> fa84069e9642ad9aa4b49624150cc345 base/pak002.pk4 "
+ echo "==> f22d8464997924e4913e467e7d62d5fe base/pak003.pk4 "
+ echo "==> 38561a3c73f93f2e6fd31abf1d4e9102 base/pak004.pk4 "
+ echo "==> "
+ echo "==> If you are also installing the Resurrection of Evil Expansion Pack, "
+ echo "==> you need to copy the following file to your d3xp/ directory "
+ echo "==> by default, /opt/doom3/d3xp "
+ echo "==> "
+ echo "==> a883fef0fd10aadeb73d34c462ff865d d3xp/pak000.pk4 "
+ echo "==> "
+ echo "==> Localization is not supported on Linux ( only english ), you should not copy over any of the zpak files. "
+ echo "==> "
+ echo "==> Start the game with the command: doom3 "
+ echo "==> Start the dedicated server with the command: doom3-dedicated "
+ echo "==> "
+ echo "==> If installed, you can start the Expansion Pack directly from the command line with the command: doom3 +set fs_game d3xp "
+ echo "==> Or you can select it in the mods menu of the base game. "
+ echo "==> "
+ echo "==> For troubleshooting and help, see: "
+ echo "==> http://zerowing.idsoftware.com/linux/ "
+ echo "==> "
+}
-For troubleshooting and help, see:
-http://zerowing.idsoftware.com/linux/
-00installInstructions00
- /bin/true
+post_remove() {
+ echo "==> To completely remove DOOM 3, you will need to manually remove"
+ echo "==> /opt/doom3/ as root"
}
op=$1
shift
+
$op $*