summarylogtreecommitdiffstats
path: root/eigen.patch
diff options
context:
space:
mode:
authorZhirui Dai2023-10-09 16:40:27 -0700
committerZhirui Dai2023-10-09 16:40:27 -0700
commit40f91fc5c4ea8a7ca7de35c3c9c646442afd0ec0 (patch)
treea49d43bfe022f18db5db20855da896dfccd7196a /eigen.patch
downloadaur-ros-noetic-hector-marker-drawing.tar.gz
0.5.2
Diffstat (limited to 'eigen.patch')
-rw-r--r--eigen.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/eigen.patch b/eigen.patch
new file mode 100644
index 000000000000..1b6d1a58b182
--- /dev/null
+++ b/eigen.patch
@@ -0,0 +1,12 @@
+--- CMakeLists.txt 2021-04-08 09:17:08.000000000 -0700
++++ CMakeLists.txt 2023-10-09 16:38:44.632188946 -0700
+@@ -4,6 +4,9 @@
+ find_package(catkin REQUIRED COMPONENTS roscpp visualization_msgs)
+
+ find_package(Eigen3 REQUIRED)
++if (NOT DEFINED EIGEN3_INCLUDE_DIRS)
++ get_target_property(EIGEN3_INCLUDE_DIRS Eigen3::Eigen INTERFACE_INCLUDE_DIRECTORIES)
++endif()
+
+ catkin_package(
+ INCLUDE_DIRS include