summarylogtreecommitdiffstats
path: root/evelauncher.sh
diff options
context:
space:
mode:
authorJernuh Zakalwe2018-10-19 17:20:42 +0200
committerJernuh Zakalwe2018-10-19 17:20:42 +0200
commitf2a93b8c75b98b0b939335e894c854b19b5fd30b (patch)
treefca9e01863c085a658e542056678e2f670d6719f /evelauncher.sh
parent9b1e3eb0d28469449f59376a3f365dc72910668b (diff)
downloadaur-f2a93b8c75b98b0b939335e894c854b19b5fd30b.tar.gz
Replaced evewinecfg and everegedit with symlinks to evewine which execute these commands now.
Changes on build_installer.sh script to handle symlinks from evewinecfg and everegedit. Handle symlinks from everegedit and evewinecfg in setup.sh.in and PKGBUILD too.
Diffstat (limited to 'evelauncher.sh')
-rw-r--r--evelauncher.sh13
1 files changed, 7 insertions, 6 deletions
diff --git a/evelauncher.sh b/evelauncher.sh
index 89dbbcfa45de..0772a32d51af 100644
--- a/evelauncher.sh
+++ b/evelauncher.sh
@@ -44,17 +44,18 @@ check_wine() {
EVECONF=$CONFDIR/EVE.conf
UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
- WINEPATH=${WINEPATH%/*}
+ CUSTOMWP=$(grep CustomWinePath $EVECONF | cut -d= -f2)
+ WINEPATH=${CUSTOMWP%/*}
+ SHAREDIR=$(grep SharedCacheFolder $EVECONF | cut -d= -f2)
+ WINEPREFIX=${SHAREDIR}wineenv
else
- launcher_msg "Error: Custom wine not set!"
+ launcher_msg "ERROR: \"Use custom Wine\" not set!"
exit 1
fi
WINEDATE=$(ls -l --time-style=+%s $WINEPATH/wineserver | cut -d' ' -f6)
- INSTWINE=$(cat $EVEDIR/SharedCache/wineenv/.update-timestamp 2>/dev/null) || true
+ INSTWINE=$(cat $WINEPREFIX/.update-timestamp 2>/dev/null) || true
if [ "x$WINEDATE" != "x$INSTWINE" ] ;then
if [ -x "$WINEPATH/wine" ] ;then
- WINEPREFIX=$EVEDIR/SharedCache/wineenv
launcher_msg "Preparing/Updating wine in $WINEPREFIX"
env WINEARCH=win32 \
WINEPREFIX=$WINEPREFIX \
@@ -70,7 +71,7 @@ check_wine() {
env WINEPREFIX=$WINEPREFIX WINE=$WINEPATH/wine \
$(which winetricks) -q winxp >/dev/null
else
- launcher_msg "Error: No wine in $WINEPATH found!"
+ launcher_msg "ERROR: \"$CUSTOMWP\" in \"Custom Wine path\" not found!"
exit 1
fi
fi