summarylogtreecommitdiffstats
path: root/evewine
diff options
context:
space:
mode:
authorJernuh Zakalwe2018-10-19 17:20:42 +0200
committerJernuh Zakalwe2018-10-19 17:20:42 +0200
commitf2a93b8c75b98b0b939335e894c854b19b5fd30b (patch)
treefca9e01863c085a658e542056678e2f670d6719f /evewine
parent9b1e3eb0d28469449f59376a3f365dc72910668b (diff)
downloadaur-f2a93b8c75b98b0b939335e894c854b19b5fd30b.tar.gz
Replaced evewinecfg and everegedit with symlinks to evewine which execute these commands now.
Changes on build_installer.sh script to handle symlinks from evewinecfg and everegedit. Handle symlinks from everegedit and evewinecfg in setup.sh.in and PKGBUILD too.
Diffstat (limited to 'evewine')
-rw-r--r--evewine19
1 files changed, 12 insertions, 7 deletions
diff --git a/evewine b/evewine
index f4243e28f96e..4bb6b3cc176c 100644
--- a/evewine
+++ b/evewine
@@ -1,18 +1,23 @@
#!/bin/sh
EVECONF=$HOME/.config/CCP/EVE.conf
-EVEDIR=$HOME/.local/lib/EVE
-
UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
- WINEPATH=${WINEPATH%/*}
+ CUSTOMWP=$(grep CustomWinePath $EVECONF | cut -d= -f2)
+ WINEPATH=${CUSTOMWP%/*}
+ SHAREDIR=$(grep SharedCacheFolder $EVECONF | cut -d= -f2)
+ WINEPREFIX=${SHAREDIR}wineenv
else
- echo "$(basename $0): Error: Custom wine not set!"
+ echo "$(basename $0): ERROR: \"Use Custom Wine\" not set!"
+ exit 1
+fi
+if [ ! -x "$WINEPATH/wine" ] ;then
+ echo "$(basename $0): ERROR: \"$CUSTOMWP\" from \"Custom Wine path\" not found!"
+ echo "$(basename $0): The full path are required (example: /usr/bin/wine)."
exit 1
fi
-env WINEPREFIX=$HOME/.local/lib/EVE/SharedCache/wineenv \
+env WINEPREFIX=$WINEPREFIX \
WINEDEBUG=-all \
WINEDLLOVERRIDES="mscoree,mshtml,winemenubuilder.exe=d" \
- $WINEPATH/wine "$@"
+ $WINEPATH/${0#*eve} "$@"