summarylogtreecommitdiffstats
path: root/external_nlopt.patch
diff options
context:
space:
mode:
authorbartus2021-01-04 13:48:25 +0100
committerbartus2021-01-04 13:48:25 +0100
commitcceb5335af1eef630993a0189f3dcca5d319f3a5 (patch)
tree2bbdc51787cfa5fba9c4312f5d0fe0acf20d4c9c /external_nlopt.patch
parentce93d2acffbb15f2d933763bed9e79f12c89b5e0 (diff)
downloadaur-hpmvs-git.tar.gz
Strip nlop internal dep.
Diffstat (limited to 'external_nlopt.patch')
-rw-r--r--external_nlopt.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/external_nlopt.patch b/external_nlopt.patch
new file mode 100644
index 000000000000..f3ec5c20d9d2
--- /dev/null
+++ b/external_nlopt.patch
@@ -0,0 +1,38 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f6cb247..5a89f65 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,7 +15,6 @@ find_package(Gflags REQUIRED)
+ add_definitions(-DHPMVS_GFLAGS_NAMESPACE=${GFLAGS_NAMESPACE})
+ find_package(Glog REQUIRED)
+
+-ADD_SUBDIRECTORY(thirdLibs/nlopt-2.4.2)
+ ADD_SUBDIRECTORY(thirdLibs/stlplus3)
+
+ set(HPMVS_SRC
+@@ -42,7 +41,7 @@ set(HPMVS_INCLUDE_DIRS
+ ${JPEG_INCLUDE_DIR}
+ ${GFLAGS_INCLUDE_DIRS}
+ ${GLOG_INCLUDE_DIRS}
+- ${PROJECT_SOURCE_DIR}/thirdLibs/nlopt-2.4.2/api
++ /usr/include
+ ${PROJECT_SOURCE_DIR}/thirdLibs/cimg
+ ${PROJECT_SOURCE_DIR}/thirdLibs/
+ ${PROJECT_SOURCE_DIR}/thirdLibs/stlplus3
+@@ -55,7 +54,6 @@ set(HPMVS_LIBRARIES
+ ${JPEG_LIBRARIES}
+ ${GFLAGS_LIBRARIES}
+ ${GLOG_LIBRARIES}
+- nlopt
+ stlplus3_hpmvs
+ )
+
+@@ -67,7 +65,7 @@ target_link_libraries(HPMVS_static ${HPMVS_LIBRARIES})
+
+ # build the executable
+ add_executable (hpmvs src/main.cpp)
+-target_link_libraries(hpmvs HPMVS_static ${HPMVS_LIBRARIES})
++target_link_libraries(hpmvs HPMVS_static ${HPMVS_LIBRARIES} nlopt)
+
+ # install path
+ install(TARGETS hpmvs RUNTIME DESTINATION bin)