summarylogtreecommitdiffstats
path: root/fix_build.patch
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-12-05 12:17:04 +0200
committerSpyros Stathopoulos2015-12-05 12:17:04 +0200
commit70ef3b3ab544650a6e0eba47089685f4379fb56a (patch)
tree1d445a3f819a46f9a1821f1b19e3832c8b32d92b /fix_build.patch
parentbd42a41c7bfada12a89cba3a862db1a0d36333e2 (diff)
downloadaur-conky19-lua-nv.tar.gz
Fix toluapp issues
Diffstat (limited to 'fix_build.patch')
-rw-r--r--fix_build.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/fix_build.patch b/fix_build.patch
new file mode 100644
index 000000000000..b9e455327b6f
--- /dev/null
+++ b/fix_build.patch
@@ -0,0 +1,18 @@
+--- orig/configure.ac.in 2012-05-04 00:35:33.000000000 +0300
++++ new/configure.ac.in 2015-12-05 12:11:35.769923821 +0200
+@@ -513,12 +513,12 @@
+ AC_DEFINE(HAVE_LUA_IMLIB2, 1, [Define if you want Lua Imlib2 bindings for Conky])
+ fi
+ fi
+- AC_CHECK_PROGS(toluapp, [tolua++ tolua++5.1 tolua++-5.1], no)
++ AC_CHECK_PROGS(toluapp, [toluapp tolua++ tolua++5.1 tolua++-5.1], no)
+ if test x$toluapp = xno; then
+- AC_MSG_ERROR([tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras.])
++ AC_MSG_ERROR([toluapp, tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras.])
+ else
+ AC_SEARCH_LIBS(tolua_error,
+- [tolua++-5.1 tolua++ tolua++5.1],
++ [toluapp tolua++-5.1 tolua++ tolua++5.1],
+ [
+ AC_SUBST(tolua_LIBS, "${LIBS}")
+ AC_SUBST(tolua_CFLAGS, "${CFLAGS}")