summarylogtreecommitdiffstats
path: root/geary-enchant2.patch
diff options
context:
space:
mode:
authorTorben2018-09-14 13:01:01 +0200
committerTorben2018-09-14 13:01:01 +0200
commit1c4938ab54f422874c95d25104c59d2592b37b12 (patch)
treedf71ce6947f54ffe2d4255316ad6347496b925e8 /geary-enchant2.patch
parentfd8815740a8d18f19babd5b8b71803b08ed5f0a1 (diff)
downloadaur-1c4938ab54f422874c95d25104c59d2592b37b12.tar.gz
Don't use explicit vapi dir in patch
Diffstat (limited to 'geary-enchant2.patch')
-rw-r--r--geary-enchant2.patch5
1 files changed, 2 insertions, 3 deletions
diff --git a/geary-enchant2.patch b/geary-enchant2.patch
index 364f24fd57f0..07bc0c98db95 100644
--- a/geary-enchant2.patch
+++ b/geary-enchant2.patch
@@ -1,7 +1,7 @@
diff --u a/meson.build b/meson.build
--- a/meson.build
+++ b/meson.build
-@@ -51,7 +51,18 @@
+@@ -51,7 +51,17 @@
webkit2gtk = dependency('webkit2gtk-4.0', version: '>=' + target_webkit)
# Secondary deps - keep sorted alphabetically
@@ -11,10 +11,9 @@ diff --u a/meson.build b/meson.build
+ dependency('enchant-2', version: '>= 1.6')
+ enchant = valac.find_library(
+ 'enchant',
-+ dirs: '/usr/share/vala-0.40/vapi/',
+ required: true
+ )
-+ # TODO These arguments should be applied more specifically
++ # TODO These arguments should be only applied where actually needed.
+ add_project_arguments('-I/usr/include/enchant-2/', language : 'c')
+ add_project_link_arguments('-lenchant-2', language : 'c')
+endif