summarylogtreecommitdiffstats
path: root/is_clang.py
diff options
context:
space:
mode:
authorEldred Habert2022-01-06 00:52:22 +0100
committerImperatorStorm2022-01-05 15:55:41 -0800
commit4bf904749f9c121eabc9e32d6be61290699ab138 (patch)
tree58963b842a8c5bdb710d257c55b0d7ec54fe3095 /is_clang.py
parente576abc19c528662b9361f4a969c35705b3a51a0 (diff)
downloadaur-4bf904749f9c121eabc9e32d6be61290699ab138.tar.gz
Use brand new PKGBUILD for Aseprite Package (#1)
* Use brand new PKGBUILD instead Attempting to fix the old one's jank * Install third-party licenses as well * Install .desktop file as well * Add missing build-time dependencies * Install icons in the icon theme directories instead Also remove redundant `$srcdir`s in `package()` * Put font license in the central directory as well * Bump pkgrel It was bumped during my work * Ignore files in subdirectories * Add missing resource files * Use underscores for local variable names https://wiki.archlinux.org/title/Arch_package_guidelines#Package_etiquette https://github.com/ImperatorStorm/PKGBUILDs/pull/1#discussion_r777122781 * Use HTTPS for upstream URL * Add myself as co-maintainer Thanks! * Remove ICU dependency We are using a statically-linked version instead, apparently * Avoid interactive prompts when patching fails * Clean up $srcdir Extract Aseprite's sources into a separate directory Configure Aseprite out-of-tree Configure Skia in a fresh directory (apparently `gn` does not support out-of-tree) * Disable Skottie in Skia This functionality doesn't appear to be used by Aseprite, and excluding it should reduce build time * Only pull Skia dependencies that we need This significantly reduces initial build time (from syncing large repos) and storage use. The only remaining dependency that has a chance to be axed is `dng_sdk`, for which more investigation is needed. * Avoid printing redundant flags in `gn` args Brainfart. "static" flags like `is_debug` were re-printed for each "non-static" (e.g. `skia_use_*`) variant. Doing it this way also allows getting rid of weird quote shenanigans. * Simplify `gn` configure line `is_official_build=true` sets Skia up to use system libs by default, so only specify those that we *don't* want * Pull `gn` version ourselves That way, we can additionally check its integrity via the SHA256 * Add forgotten `libgl` dependency What's weird is that the lib seems not to be linked to dynamically, but I can't see it not being required at run time. Right? * Maybe use system libwebp? Based on https://patch-diff.githubusercontent.com/raw/aseprite/aseprite/pull/2535.patch * Fix system `libwebp`, add `pixman` as makedep * possibly fix shared-libwebp.patch? * Disable updater https://github.com/ImperatorStorm/PKGBUILDs/pull/1#issuecomment-1003838784 * Avoid creating symlinks to Skia deps in their dirs Would occur if they were already symlinked * Use system HarfBuzz and FreeType I remember getting build errors, but cannot reproduce them anymore. So use the system libs more where possible! * Find all WebP libs * Mark libwebp as runtime dep * Remove CMake variables used by libwebp build They do nothing now that we are using shared libwebp * Remove build-time dep on Pixman It doesn't wind up being used at all in the end * Trim off a bunch of dependencies from Skia Only libpng is required to render some of the images, it seems, so this reduces build time and the amount of sources, which is good! Co-authored-by: ImperatorStorm <30777770+ImperatorStorm@users.noreply.github.com>
Diffstat (limited to 'is_clang.py')
-rwxr-xr-xis_clang.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/is_clang.py b/is_clang.py
new file mode 100755
index 000000000000..5209d533ceac
--- /dev/null
+++ b/is_clang.py
@@ -0,0 +1,17 @@
+#!/usr/bin/env python3
+#
+# Copyright 2016 Google Inc.
+#
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+import subprocess
+import sys
+cc,cxx = sys.argv[1:3]
+
+if (b'clang' in subprocess.check_output('%s --version' % cc, shell=True) and
+ b'clang' in subprocess.check_output('%s --version' % cxx, shell=True)):
+ print('true')
+else:
+ print('false')
+