summarylogtreecommitdiffstats
path: root/make.patch
diff options
context:
space:
mode:
authorava1ar2016-02-13 16:50:34 -0500
committerava1ar2016-02-13 16:50:34 -0500
commit4b121d88513bd705e1f9ec4731c284380f2d7591 (patch)
tree259a1038b17865679467ca1484bb95cf3360fc4c /make.patch
parent5d75e36f29e013e85982ef2f0b31c606c7dd4bd0 (diff)
downloadaur-fb2toepub.tar.gz
Fix build issue
Diffstat (limited to 'make.patch')
-rw-r--r--make.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/make.patch b/make.patch
new file mode 100644
index 000000000000..3e0659bb8097
--- /dev/null
+++ b/make.patch
@@ -0,0 +1,26 @@
+--- a/Makefile 2010-12-31 14:41:36.000000000 -0500
++++ b/Makefile 2016-02-13 16:06:51.354411602 -0500
+@@ -67,19 +67,19 @@
+ # default flags
+ CFLAGS= -O2 -D FB2TOEPUB_VERSION="$(VERSION)" -I$(incdir)
+
+-all : makedirs $(distdir)/fb2toepub
++all : makedirs scanner $(distdir)/fb2toepub
+
+ makedirs :
+ mkdir -p $(objdir)
+ mkdir -p $(distdir)
+
++scanner : $(srcdir)/scanner.cpp $(srcdir)/scanner.l
++ flex -o $^
++
+ $(distdir)/fb2toepub : $(COBJ)
+ g++ -o $@ $(COBJ) -lz
+ strip $@
+
+-$(srcdir)/scanner.cpp : $(srcdir)/scanner.l
+- flex -o$@ $<
+-
+ $(objdir)/%.o : $(srcdir)/%.cpp $(HSRC)
+ g++ $(CFLAGS) -o $@ -c $<
+