summarylogtreecommitdiffstats
path: root/makefile-fixes.patch
diff options
context:
space:
mode:
authorRod Kay2023-01-12 20:17:37 +1100
committerRod Kay2023-01-12 20:17:37 +1100
commit3d14e7b43bf4d4fd8a3b729f5e5e84027163caa8 (patch)
treef0c5bad0b934bb03283215ff8b3c249bf6b12788 /makefile-fixes.patch
downloadaur-spark2014.tar.gz
Add initial PKGBUILD.
Diffstat (limited to 'makefile-fixes.patch')
-rw-r--r--makefile-fixes.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/makefile-fixes.patch b/makefile-fixes.patch
new file mode 100644
index 000000000000..5ac4bf219ad7
--- /dev/null
+++ b/makefile-fixes.patch
@@ -0,0 +1,24 @@
+diff --color --unified --recursive --text src.orig/spark2014/Makefile src.new/spark2014/Makefile
+--- src.orig/spark2014/Makefile 2022-05-12 14:41:28.440880794 -0600
++++ src.new/spark2014/Makefile 2022-05-12 14:44:29.869703151 -0600
+@@ -77,9 +77,9 @@
+ # install-all install of gnatprove and why3
+
+ setup:
+- cd why3 && ./configure --prefix=$(INSTALLDIR)/libexec/spark \
++ cd why3 && ./configure --prefix=$(INSTALLDIR)/lib/spark \
+ --enable-relocation --disable-js-of-ocaml \
+- --disable-hypothesis-selection --disable-re
++ --disable-hypothesis-selection --disable-re --disable-emacs-compilation
+
+ why3:
+ $(MAKE) -C why3 -j $(nproc)
+@@ -89,7 +89,7 @@
+ $(MAKE) install
+ $(MAKE) -C why3 install_spark2014_dev
+ # Create the fake prover scripts to help extract benchmarks.
+- $(CP) benchmark_script/fake_* install/libexec/spark/bin
++ $(CP) benchmark_script/fake_* $(INSTALLDIR)/lib/spark/bin
+
+ install:
+ mkdir -p $(INSTALLDIR)/bin $(CONFIGDIR) $(THEORIESDIR) \