aboutsummarylogtreecommitdiffstats
path: root/makefile_1.6.patch
diff options
context:
space:
mode:
authorJörg Schuck2017-12-06 14:28:57 +0100
committerJörg Schuck2017-12-06 14:28:57 +0100
commit500050a67075b27b5d3f74cfc8424fb221e9328e (patch)
tree61fe56cffadf1a6048172625e41725f5c9564dc9 /makefile_1.6.patch
parent087455dff7ee4352eeeb332b65bccc2ca66f5be5 (diff)
downloadaur-500050a67075b27b5d3f74cfc8424fb221e9328e.tar.gz
Versioning.
Diffstat (limited to 'makefile_1.6.patch')
-rw-r--r--makefile_1.6.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/makefile_1.6.patch b/makefile_1.6.patch
new file mode 100644
index 000000000000..55151c5fc9f7
--- /dev/null
+++ b/makefile_1.6.patch
@@ -0,0 +1,22 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 17cf8c2..9db81f8 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,6 +1,7 @@
+ SUBDIRS=. aspell ispell uspell myspell hspell applespell voikko zemberek
+
+-AM_CPPFLAGS=-I$(top_srcdir) $(ENCHANT_CFLAGS) $(CC_WARN_CFLAGS) -DENCHANT_GLOBAL_MODULE_DIR=\"$(libdir)/enchant\" -DENCHANT_GLOBAL_ORDERING=\"$(datadir)/enchant\" -D_ENCHANT_BUILD=1 -DENCHANT_VERSION_STRING=\"@ENCHANT_MAJOR_VERSION@.@ENCHANT_MINOR_VERSION@.@ENCHANT_MICRO_VERSION@\"
++AM_CPPFLAGS=-I$(top_srcdir) $(ENCHANT_CFLAGS) $(CC_WARN_CFLAGS) -DENCHANT_GLOBAL_MODULE_DIR=\"$(libdir)/enchant1.6\" -DENCHANT_GLOBAL_ORDERING=\"$(datadir)/enchant1.6\"
++-D_ENCHANT_BUILD=1 -DENCHANT_VERSION_STRING=\"@ENCHANT_MAJOR_VERSION@.@ENCHANT_MINOR_VERSION@.@ENCHANT_MICRO_VERSION@\"
+
+ lib_LTLIBRARIES = libenchant.la
+
+@@ -16,7 +17,7 @@ endif
+ libenchant_la_DEPENDENCIES = @ENCHANT_WIN32_RESOURCE@
+ libenchant_la_SOURCES = enchant.c pwl.c enchant.h pwl.h
+
+-libenchant_includedir = $(includedir)/enchant
++libenchant_includedir = $(includedir)/enchant1.6
+ libenchant_include_HEADERS = enchant.h enchant-provider.h enchant++.h
+
+ if WITH_APPLESPELL