summarylogtreecommitdiffstats
path: root/nm.py.patch
diff options
context:
space:
mode:
authorTrygve Aaberge2020-06-18 10:41:55 +0200
committerTrygve Aaberge2020-06-18 10:49:50 +0200
commit365ae61cd037fab7e05942a3b68a34ce1b5a0c59 (patch)
tree0c3e477fec626ad89850a1f69095995f5b42149b /nm.py.patch
downloadaur-appgate-sdp-5.0.tar.gz
Initial version
Copied from appgate-sdp-5 and changed version to 5.0.
Diffstat (limited to 'nm.py.patch')
-rw-r--r--nm.py.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/nm.py.patch b/nm.py.patch
new file mode 100644
index 000000000000..3e2d5c4050e1
--- /dev/null
+++ b/nm.py.patch
@@ -0,0 +1,13 @@
+--- nm.py-5.1.3.orig 2020-06-03 18:30:33.236358565 +0100
++++ nm.py-5.1.3.arch 2020-06-03 18:30:17.606358578 +0100
+@@ -276,7 +276,9 @@
+ syslog(LOG_INFO, '[has_system_dnsmasq] dnsmasq bus present')
+ return True
+
+- if platform.linux_distribution()[0] != 'Fedora':
++ # this is PKGBUILD for Arch so this check should always yield True
++ # if platform.linux_distribution()[0] != 'Fedora':
++ if True:
+ try:
+ bus = dbus.SystemBus()
+ proxy = bus.get_object(