summarylogtreecommitdiffstats
path: root/python-config-32.patch
diff options
context:
space:
mode:
authorArzet Ro2024-05-06 10:08:32 +0000
committerArzet Ro2024-05-06 10:08:32 +0000
commitf1abd5e055fbc73768ab1f38771fbf7efa642a43 (patch)
tree6dd8bb21ea2fcc3fbebe3bb9026453815a30f3ae /python-config-32.patch
parentfa81f39e2957f032ccf4e195eb1d71225753b801 (diff)
downloadaur-lib32-python.tar.gz
Upgrade to 3.12.3
Diffstat (limited to 'python-config-32.patch')
-rw-r--r--python-config-32.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/python-config-32.patch b/python-config-32.patch
index 7e63944e8e7d..fa60d142e31f 100644
--- a/python-config-32.patch
+++ b/python-config-32.patch
@@ -1,7 +1,7 @@
-diff -ruN Python-3.11.3/Makefile.pre.in Python-3.11.3.new/Makefile.pre.in
---- Python-3.11.3/Makefile.pre.in 2023-04-05 01:52:17.000000000 +0330
-+++ Python-3.11.3.new/Makefile.pre.in 2023-05-19 09:34:30.419545166 +0330
-@@ -1850,15 +1850,15 @@
+diff -ruN Python-3.12.3/Makefile.pre.in Python-3.12.3.new/Makefile.pre.in
+--- Python-3.12.3/Makefile.pre.in 2023-04-05 01:52:17.000000000 +0330
++++ Python-3.12.3.new/Makefile.pre.in 2023-05-19 09:34:30.419545166 +0330
+@@ -2032,15 +2032,15 @@
fi
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python3$(EXE))
-if test "$(VERSION)" != "$(LDVERSION)"; then \
@@ -20,9 +20,9 @@ diff -ruN Python-3.11.3/Makefile.pre.in Python-3.11.3.new/Makefile.pre.in
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python3.pc)
-rm -f $(DESTDIR)$(LIBPC)/python3-embed.pc
-@@ -2123,12 +2123,12 @@
+@@ -2346,12 +2346,12 @@
@ # is not available in configure
- sed -e "s,@EXENAME@,$(BINDIR)/python$(LDVERSION)$(EXE)," < $(srcdir)/Misc/python-config.in >python-config.py
+ sed -e "s,@EXENAME@,$(EXENAME)," < $(srcdir)/Misc/python-config.in >python-config.py
@ # Replace makefile compat. variable references with shell script compat. ones; $(VAR) -> ${VAR}
- LC_ALL=C sed -e 's,\$$(\([A-Za-z0-9_]*\)),\$$\{\1\},g' < Misc/python-config.sh >python-config
+ LC_ALL=C sed -e 's,\$$(\([A-Za-z0-9_]*\)),\$$\{\1\},g' < Misc/python-config.sh >python$(EXE)-config
@@ -35,16 +35,16 @@ diff -ruN Python-3.11.3/Makefile.pre.in Python-3.11.3.new/Makefile.pre.in
fi
-@@ -2212,7 +2212,7 @@
+@@ -2462,7 +2462,7 @@
$(INSTALL_SCRIPT) $(srcdir)/Modules/makesetup $(DESTDIR)$(LIBPL)/makesetup
$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
$(INSTALL_SCRIPT) python-config.py $(DESTDIR)$(LIBPL)/python-config.py
- $(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(LDVERSION)-config
+ $(INSTALL_SCRIPT) python$(EXE)-config $(DESTDIR)$(BINDIR)/python$(LDVERSION)$(EXE)-config
- @if [ -s Modules/python.exp -a \
- "`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
- echo; echo "Installing support files for building shared extension modules on AIX:"; \
-@@ -2435,7 +2435,7 @@
+ $(INSTALL_SCRIPT) $(SCRIPT_2TO3) $(DESTDIR)$(BINDIR)/2to3-$(VERSION)
+ $(INSTALL_SCRIPT) $(SCRIPT_IDLE) $(DESTDIR)$(BINDIR)/idle$(VERSION)
+ $(INSTALL_SCRIPT) $(SCRIPT_PYDOC) $(DESTDIR)$(BINDIR)/pydoc$(VERSION)
+@@ -2699,7 +2699,7 @@
config.cache config.log pyconfig.h Modules/config.c
-rm -rf build platform
-rm -rf $(PYTHONFRAMEWORKDIR)