summarylogtreecommitdiffstats
path: root/remove-vcpkg-dependency.patch
diff options
context:
space:
mode:
authorCarl Smedstad2023-11-19 18:12:16 +0100
committerCarl Smedstad2023-12-05 15:45:20 +0100
commit836423f63aafac8919cc49efd0c9d519f71d5c34 (patch)
treee88c8d83b63a3cef99bf48ddc0891fec4ccc9289 /remove-vcpkg-dependency.patch
parentb0453964983c7d3763ecde2544b43f82c96971fd (diff)
downloadaur-836423f63aafac8919cc49efd0c9d519f71d5c34.tar.gz
Publish version 3.6.1-3 - Major refactoring
* Remove vcpkg dependency and dynamically link to system dependencies. This massively reduces the build time as we don't have to build for example curl & zlib from source. * Depend on system Qt instead of bundling it. Brings installed package size down to 30.18 MiB. * Add a check() stage running the googletest suite and a subset of the Go unit test suite. * Set proper LDFLAGS for the Go build. This PKGBUILD passes namcap without any warnings.
Diffstat (limited to 'remove-vcpkg-dependency.patch')
-rw-r--r--remove-vcpkg-dependency.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/remove-vcpkg-dependency.patch b/remove-vcpkg-dependency.patch
new file mode 100644
index 000000000000..2ba40a79a589
--- /dev/null
+++ b/remove-vcpkg-dependency.patch
@@ -0,0 +1,28 @@
+diff --unified --recursive --text proton-bridge-3.6.1.orig/internal/frontend/bridge-gui/BridgeSetup.cmake proton-bridge-3.6.1/internal/frontend/bridge-gui/BridgeSetup.cmake
+--- proton-bridge-3.6.1.orig/internal/frontend/bridge-gui/BridgeSetup.cmake 2023-11-21 15:03:10.865099608 +0100
++++ proton-bridge-3.6.1/internal/frontend/bridge-gui/BridgeSetup.cmake 2023-11-21 15:03:34.591823916 +0100
+@@ -51,17 +51,6 @@
+ # We rely on vcpkg for to get gRPC / Protobuf
+ # run build.sh / build.ps1 to get gRPC / Protobuf and dependencies installed.
+
+-set(VCPKG_ROOT "${BRIDGE_REPO_ROOT}/extern/vcpkg")
+-message(STATUS "VCPKG_ROOT is ${VCPKG_ROOT}")
+-if (WIN32)
+- find_program(VCPKG_EXE "${VCPKG_ROOT}/vcpkg.exe")
+-else()
+- find_program(VCPKG_EXE "${VCPKG_ROOT}/vcpkg")
+-endif()
+-if (NOT VCPKG_EXE)
+- message(FATAL_ERROR "vcpkg is not installed. Run build.sh (macOS/Linux) or build.ps1 (Windows) first.")
+-endif()
+-
+ # For now we support only a single architecture for macOS (ARM64 or x86_64). We need to investigate how to build universal binaries with vcpkg.
+ if (APPLE)
+ if (NOT DEFINED CMAKE_OSX_ARCHITECTURES)
+@@ -86,5 +75,3 @@
+ message(STATUS "Building for Intel x64 Windows computers")
+ set(VCPKG_TARGET_TRIPLET x64-windows)
+ endif()
+-
+-set(CMAKE_TOOLCHAIN_FILE "${VCPKG_ROOT}/scripts/buildsystems/vcpkg.cmake" CACHE STRING "toolchain")
+\ No newline at end of file