summarylogtreecommitdiffstats
path: root/reproducible-builds.patch
diff options
context:
space:
mode:
authorPatrick Lühne2020-11-25 21:30:55 +0100
committerPatrick Lühne2020-11-25 21:30:55 +0100
commit8642fdfd1009c880620396d634c5a5faac9f606e (patch)
treeddab93860fdfc965514fef7f4d8249d17ff939b0 /reproducible-builds.patch
parent51cbd2f5dab38672f8de895c5996e275f52d2ba1 (diff)
downloadaur-vampire.tar.gz
Update Vampire to 4.5
Vampire now supports building with CMake, so use that instead of the handwritten Makefile. The separate patch is used for two reasons. First, Vampire includes the current Git commit information in its --version output (commit hash and timestamp). When building this package from AUR, this would read the commit metadata from AUR and not the Vampire repository. Second, Vampire uses the __FILE__ macro even in release builds, which means that references to the build directory end up in the binary. To avoid this, a GCC- and Clang-specific compiler option is added to ensure that the file references are relative to Vampire’s source directory.
Diffstat (limited to 'reproducible-builds.patch')
-rw-r--r--reproducible-builds.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/reproducible-builds.patch b/reproducible-builds.patch
new file mode 100644
index 000000000000..ace9ac4308b8
--- /dev/null
+++ b/reproducible-builds.patch
@@ -0,0 +1,20 @@
+diff -Naur package.orig/CMakeLists.txt package.new/CMakeLists.txt
+--- package.orig/CMakeLists.txt
++++ package.new/CMakeLists.txt
+@@ -862,6 +862,16 @@
+ set(VAMPIRE_BINARY_REV_COUNT "_${GIT_REV_COUNT}")
+ endif()
+
++set(VAMPIRE_AUR_GIT_COMMIT_DESCRIPTION "" CACHE STRING "Overwrite the automatically generated commit description")
++set(VAMPIRE_BINARY_BUILD "")
++set(VAMPIRE_BINARY_STATIC "")
++set(VAMPIRE_BINARY_Z3 "")
++set(VAMPIRE_BINARY_HASH "")
++set(VAMPIRE_BINARY_BRANCH "")
++set(VAMPIRE_BINARY_REV_COUNT "")
++set(GIT_COMMIT_DESCRIPTION "${VAMPIRE_AUR_GIT_COMMIT_DESCRIPTION}")
++target_compile_options(vampire PUBLIC "-fmacro-prefix-map=${CMAKE_SOURCE_DIR}=.")
++
+ ################# set binary name #######################
+ set(VAMPIRE_BINARY "vampire${VAMPIRE_BINARY_Z3}${VAMPIRE_BINARY_BUILD}${VAMPIRE_BINARY_STATIC}${VAMPIRE_BINARY_BRANCH}${VAMPIRE_BINARY_REV_COUNT}")
+ message(STATUS "Setting binary name to " "${VAMPIRE_BINARY}")