summarylogtreecommitdiffstats
path: root/shared-skia-deps.patch
diff options
context:
space:
mode:
authorISSOtm2022-01-13 19:24:40 +0100
committerISSOtm2022-01-13 19:32:37 +0100
commit9078bc1fac8f3ef0ea659a94417a8c96eb0688e9 (patch)
tree523e70ce1fa342168f786d3651935726b636bc7f /shared-skia-deps.patch
parenta58e729f86c79edce7629d42752dc423e0736d21 (diff)
downloadaur-9078bc1fac8f3ef0ea659a94417a8c96eb0688e9.tar.gz
Fix build
Use more recent `gn` Disable some functionality to broke the build (whether we should enable it back remains TBD) Change Skia flags to fix up dependencies Apply patch so missing Skia deps don't break Aseprite's build Many of these changes were imported from my work on `aseprite-git` https://github.com/ISSOtm/PKGBUILDs/tree/aseprite-git/aseprite-git
Diffstat (limited to 'shared-skia-deps.patch')
-rw-r--r--shared-skia-deps.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/shared-skia-deps.patch b/shared-skia-deps.patch
new file mode 100644
index 000000000000..77bdebc8b06d
--- /dev/null
+++ b/shared-skia-deps.patch
@@ -0,0 +1,21 @@
+--- src/laf/cmake/FindSkia.cmake.orig 2022-01-08 02:15:13.417619266 +0100
++++ src/laf/cmake/FindSkia.cmake 2022-01-08 02:15:43.603960491 +0100
+@@ -32,14 +32,18 @@
+ # SkShaper module + freetype + harfbuzz
+ find_library(SKSHAPER_LIBRARY skshaper PATH "${SKIA_LIBRARY_DIR}")
+
++if(NOT USE_SHARED_FREETYPE)
+ set(FREETYPE_FOUND ON)
+ find_library(FREETYPE_LIBRARY freetype2 PATH "${SKIA_LIBRARY_DIR}" NO_DEFAULT_PATH)
+ set(FREETYPE_LIBRARIES ${FREETYPE_LIBRARY})
+ set(FREETYPE_INCLUDE_DIRS "${SKIA_DIR}/third_party/externals/freetype/include")
++endif()
+
++if(NOT USE_SHARED_HARFBUZZ)
+ find_library(HARFBUZZ_LIBRARY harfbuzz PATH "${SKIA_LIBRARY_DIR}" NO_DEFAULT_PATH)
+ set(HARFBUZZ_LIBRARIES ${HARFBUZZ_LIBRARY})
+ set(HARFBUZZ_INCLUDE_DIRS "${SKIA_DIR}/third_party/externals/harfbuzz/src")
++endif()
+
+ set(SKIA_LIBRARIES
+ ${SKIA_LIBRARY}