summarylogtreecommitdiffstats
path: root/ssl.patch
diff options
context:
space:
mode:
authorStephen Martin2017-05-01 18:20:04 -0500
committerStephen Martin2017-05-01 18:20:04 -0500
commit775d0b28c85a19f12a26479b624dc4eb2f300d02 (patch)
tree56ba77e2898f2990c573feeba51323fe5310f2e9 /ssl.patch
parent4cd4c8da45900753c0bbb9f7b1756b6525462b7d (diff)
downloadaur-775d0b28c85a19f12a26479b624dc4eb2f300d02.tar.gz
Fixed to work with openssl 1.0
Arch just updated to openssl 1.1. Rstudio-server requires openssl 1.0. - Added wget to depends as per a user's request - Patched out a socketproxy stream bug as seen in rstudio-desktop-git - Patched to change includes from openssl to openssl-1.0 - Patched to change cmake files to link against openssl-1.0
Diffstat (limited to 'ssl.patch')
-rw-r--r--ssl.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/ssl.patch b/ssl.patch
new file mode 100644
index 000000000000..003540200d77
--- /dev/null
+++ b/ssl.patch
@@ -0,0 +1,40 @@
+--- a/src/cpp/core/system/PosixCrypto.cpp
++++ b/src/cpp/core/system/PosixCrypto.cpp
+@@ -18,13 +18,13 @@
+
+ #include <fcntl.h>
+
+-#include <openssl/err.h>
+-#include <openssl/hmac.h>
+-#include <openssl/bio.h>
+-#include <openssl/buffer.h>
+-#include <openssl/pem.h>
+-#include <openssl/rand.h>
+-#include <openssl/rsa.h>
++#include <openssl-1.0/openssl/err.h>
++#include <openssl-1.0/openssl/hmac.h>
++#include <openssl-1.0/openssl/bio.h>
++#include <openssl-1.0/openssl/buffer.h>
++#include <openssl-1.0/openssl/pem.h>
++#include <openssl-1.0/openssl/rand.h>
++#include <openssl-1.0/openssl/rsa.h>
+
+ #include <algorithm>
+
+--- a/src/cpp/core/CMakeLists.txt
++++ b/src/cpp/core/CMakeLists.txt
+@@ -200,7 +200,12 @@ if (UNIX)
+ endif()
+
+ if(RSTUDIO_SERVER)
+- find_package(OpenSSL REQUIRED QUIET)
++ # find_package(OpenSSL REQUIRED QUIET)
++ find_library(SSL ssl PATHS /usr/lib/openssl-1.0)
++ find_library(CRYPTO crypto PATHS /usr/lib/openssl-1.0)
++ set(OPENSSL_INCLUDE_DIRS /usr/include/openssl-1.0)
++ #set(OPENSSL_LIBRARIES ${SSL} ${CRYPTO} )
++ set(OPENSSL_LIBRARIES /usr/lib/openssl-1.0/libssl.so /usr/lib/openssl-1.0/libcrypto.so)
+ find_package(PAM REQUIRED)
+ set(CORE_SYSTEM_LIBRARIES
+ ${CORE_SYSTEM_LIBRARIES}
+