summarylogtreecommitdiffstats
path: root/use-opencv3.patch
diff options
context:
space:
mode:
authorJan-Henrik Bruhn2020-05-21 16:08:02 +0200
committerGitHub2020-05-21 10:08:02 -0400
commitababe5765b272bd524cf37c1669211178f667faa (patch)
tree093194877bc67447a6a7fbe93a69fc179b7ab1d7 /use-opencv3.patch
parent03c9b48e4b61fc28797074966fbef53755599cc0 (diff)
downloadaur-ros-melodic-image-geometry.tar.gz
Add Patch to explictly use OpenCV3 during build (#2)
Diffstat (limited to 'use-opencv3.patch')
-rw-r--r--use-opencv3.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/use-opencv3.patch b/use-opencv3.patch
new file mode 100644
index 000000000000..068bd2af2d28
--- /dev/null
+++ b/use-opencv3.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text package.orig/vision_opencv-1.13.0/image_geometry/CMakeLists.txt package.new/vision_opencv-1.13.0/image_geometry/CMakeLists.txt
+--- package.orig/vision_opencv-1.13.0/image_geometry/CMakeLists.txt 2020-05-21 15:32:19.474961287 +0200
++++ package.new/vision_opencv-1.13.0/image_geometry/CMakeLists.txt 2020-05-21 15:32:33.155009735 +0200
+@@ -2,7 +2,7 @@
+ project(image_geometry)
+
+ find_package(catkin REQUIRED sensor_msgs)
+-find_package(OpenCV REQUIRED)
++find_package(OpenCV 3 REQUIRED)
+
+ catkin_package(CATKIN_DEPENDS sensor_msgs
+ DEPENDS OpenCV