summarylogtreecommitdiffstats
path: root/vmmon.patch
diff options
context:
space:
mode:
authorJean-Marc Lenoir2019-09-22 19:45:44 +0200
committerJean-Marc Lenoir2019-09-22 20:16:11 +0200
commit71949ee2fb285067213f3c312d405f859f34c8aa (patch)
treea21fcbe2bfb9f960daf36e7d0653d4394ebfbd83 /vmmon.patch
parent6b8ec3ab2f0f381dfd85549e405777782fc78cf2 (diff)
downloadaur-71949ee2fb285067213f3c312d405f859f34c8aa.tar.gz
Sync with vmware-workstation 15.5.0
Diffstat (limited to 'vmmon.patch')
-rw-r--r--vmmon.patch210
1 files changed, 68 insertions, 142 deletions
diff --git a/vmmon.patch b/vmmon.patch
index 2f488d613f1f..e4cbb6f4b56e 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -12,6 +12,56 @@
# Header directory for the running kernel
ifdef LINUXINCLUDE
+@@ -98,6 +98,13 @@ auto-build: $(DRIVER_KO)
+ $(DRIVER): $(DRIVER_KO)
+ if [ $< -nt $@ ] || [ ! -e $@ ] ; then cp -f $< $@; fi
+
++# Use SUBDIRS on 2.x, 3.x, 4.x. Use M on newer kernels.
++ifeq ($(filter-out 2 3 4,$(firstword $(subst ., ,$(VM_UNAME)))),)
++DIRVAR := SUBDIRS
++else
++DIRVAR := M
++endif
++
+ #
+ # Define a setup target that gets built before the actual driver.
+ # This target may not be used at all, but if it is then it will be defined
+@@ -107,7 +114,7 @@ prebuild:: ;
+ postbuild:: ;
+
+ $(DRIVER_KO): prebuild
+- $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
++ $(MAKE) -C $(BUILD_DIR) $(DIRVAR)=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
+ MODULEBUILDDIR=$(MODULEBUILDDIR) modules
+ $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
+ MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
+--- a/vmmon/linux/driver.c
++++ b/vmmon/linux/driver.c
+@@ -96,7 +95,9 @@ long LinuxDriver_Ioctl(struct file *filp, u_int iocmd,
+ unsigned long ioarg);
+
+ static int LinuxDriver_Close(struct inode *inode, struct file *filp);
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 17, 0)
++static vm_fault_t LinuxDriverFault(struct vm_fault *fault);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
+ static int LinuxDriverFault(struct vm_fault *fault);
+ #else
+ static int LinuxDriverFault(struct vm_area_struct *vma, struct vm_fault *fault);
+@@ -594,7 +596,12 @@ LinuxDriver_Close(struct inode *inode, // IN
+ *-----------------------------------------------------------------------------
+ */
+
+-static int
++static
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 17, 0)
++vm_fault_t
++#else
++int
++#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
+ LinuxDriverFault(struct vm_fault *fault) //IN/OUT
+ #else
--- a/vmmon/linux/hostif.c
+++ a/vmmon/linux/hostif.c
@@ -1499,9 +1499,13 @@
@@ -118,65 +168,7 @@
#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 15, 0) && !defined(timer_setup)
init_timer(&uptimeState.timer);
-@@ -3200,7 +3243,12 @@
-
- ASSERT(handle);
-
-- if (!access_ok(VERIFY_WRITE, p, size)) {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
-+ if (!access_ok(VERIFY_WRITE, p, size))
-+#else
-+ if (!access_ok(p, size))
-+#endif
-+ {
- printk(KERN_ERR "%s: Couldn't verify write to uva 0x%p with size %"
- FMTSZ"u\n", __func__, p, size);
-
-From 8ba37a5023f939ba8d2e0d91b916ff442b1c18dd Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Mon, 31 Dec 2018 00:05:42 +0100
-Subject: [PATCH] modules: replace SUBDIRS with M
-
-Since commit 0126be38d988 ("kbuild: announce removal of SUBDIRS if used")
-in v5.0-rc1, using SUBDIRS when building out of tree modules produces
-a deprecation warning. As M used to work since pretty much ever, use it
-unconditionally.
----
- vmmon-only/Makefile | 2 +-
- vmnet-only/Makefile | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/vmmon-only/Makefile b/vmmon-only/Makefile
-index ccdd295..b4b71fb 100644
---- a/vmmon-only/Makefile
-+++ b/vmmon-only/Makefile
-@@ -111,7 +111,7 @@ prebuild:: ;
- postbuild:: ;
-
- $(DRIVER_KO): prebuild
-- $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
-+ $(MAKE) -C $(BUILD_DIR) M=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) modules
- $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
- MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
-From 41413a9b6e660a93600a438944d85b6f51eb680c Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Tue, 5 Mar 2019 13:21:35 +0100
-Subject: [PATCH] vmmon: use KERNEL_DS rather than get_ds()
-
-Commit 736706bee329 ("get rid of legacy 'get_ds()' function") in v5.1-rc1
-removed get_ds() helper. As this helper always returned KERNEL_DS on x86_64
-since the architecture was introduced (and even on i386, it did so since
-v2.1.0), simply use KERNEL_DS regardless of kernel version.
----
- vmmon-only/linux/hostif.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
-index ef88a22..8ca17de 100644
---- a/vmmon-only/linux/hostif.c
-+++ b/vmmon-only/linux/hostif.c
-@@ -2207,7 +2207,7 @@ isVAReadable(VA r) // IN:
+@@ -2164,7 +2207,7 @@ isVAReadable(VA r) // IN:
int ret;
old_fs = get_fs();
@@ -185,7 +177,7 @@ index ef88a22..8ca17de 100644
r = APICR_TO_ADDR(r, APICR_VERSION);
ret = HostIF_CopyFromUser(&dummy, r, sizeof dummy);
set_fs(old_fs);
-@@ -2408,7 +2408,7 @@ HostIF_SemaphoreWait(VMDriver *vm, // IN:
+@@ -2365,7 +2408,7 @@ HostIF_SemaphoreWait(VMDriver *vm, // IN:
}
old_fs = get_fs();
@@ -194,7 +186,7 @@ index ef88a22..8ca17de 100644
{
struct poll_wqueues table;
-@@ -2537,7 +2537,7 @@ HostIF_SemaphoreSignal(uint64 *args) // IN:
+@@ -2494,7 +2537,7 @@ HostIF_SemaphoreSignal(uint64 *args) // IN:
}
old_fs = get_fs();
@@ -203,91 +195,25 @@ index ef88a22..8ca17de 100644
/*
* Always write sizeof(uint64) bytes. This works fine for eventfd and
-From 2af9d566d0ccc78a93b46a79d23902e5ba2bc933 Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Sat, 9 Mar 2019 11:11:29 +0100
-Subject: [PATCH] vmmon: fix return type of vm_operations_struct::fault handler
-
-Commit 3d3539018d2c ("mm: create the new vm_fault_t type") in mainline
-5.1-rc1 changed the definition of vm_fault_t type to unsigned to catch
-vm_operations_struct::fault handlers which still have int as return value.
-LinuxDriverFault() in vmmon module is one of those.
-
-As handler return type was changed by commit 1c8f422059ae ("mm: change
-return type to vm_fault_t") in 4.17-rc1, make LinuxDriverFault() always
-return vm_fault_t and define vm_fault_t as int when building against
-a pre-4.17 kernel.
----
- vmmon-only/linux/driver.c | 9 ++++++---
- 1 file changed, 6 insertions(+), 3 deletions(-)
-
-diff --git a/vmmon-only/linux/driver.c b/vmmon-only/linux/driver.c
-index 92a3529..248a95d 100644
---- a/vmmon-only/linux/driver.c
-+++ b/vmmon-only/linux/driver.c
-@@ -73,6 +73,9 @@ static Bool LinuxDriverCheckPadding(void);
-
- struct VMXLinuxState linuxState;
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 17, 0)
-+typedef int vm_fault_t;
-+#endif
-
- /*
- *----------------------------------------------------------------------
-@@ -97,9 +100,9 @@ long LinuxDriver_Ioctl(struct file *filp, u_int iocmd,
-
- static int LinuxDriver_Close(struct inode *inode, struct file *filp);
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
--static int LinuxDriverFault(struct vm_fault *fault);
-+static vm_fault_t LinuxDriverFault(struct vm_fault *fault);
- #else
--static int LinuxDriverFault(struct vm_area_struct *vma, struct vm_fault *fault);
-+static vm_fault_t LinuxDriverFault(struct vm_area_struct *vma, struct vm_fault *fault);
- #endif
- static int LinuxDriverMmap(struct file *filp, struct vm_area_struct *vma);
-
-@@ -594,7 +597,7 @@ LinuxDriver_Close(struct inode *inode, // IN
- *-----------------------------------------------------------------------------
- */
-
--static int
-+static vm_fault_t
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
- LinuxDriverFault(struct vm_fault *fault) //IN/OUT
- #else
-From 98008ff6adec118962df8ac26f814b55c3861efb Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Tue, 9 Jul 2019 21:07:04 +0200
-Subject: [PATCH] vmmon: fix HostIF_SetFastClockRate() not to use force_sig()
-
-Commit 3cf5d076fb4d ("signal: Remove task parameter from force_sig") in
-v5.3-rc1 drops second argument of force_sig(); before that, all callers
-which passed something else than current task as second argument were
-fixed, mostly to use send_sig() instead.
-
-The situation in HostIF_SetFastClockRate() is the same as e.g. in bpfilter
-call fixed by commit 1dfd1711de29 ("signal/bpfilter: Fix bpfilter_kernl to
-use send_sig not force_sig"): locking in force_sig_info() cannot handle
-task exiting and using force_sig() for SIGKILL is pointless anyway as this
-signal cannot be blocked.
-
-As send_sig() is present with unchanged signature since the pre-git era, we
-can use send_sig() unconditionally, regardless of kernel version.
----
- vmmon-only/linux/hostif.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
-index 850ca02..27eb60c 100644
---- a/vmmon-only/linux/hostif.c
-+++ b/vmmon-only/linux/hostif.c
-@@ -3197,7 +3197,7 @@ HostIF_SetFastClockRate(unsigned int rate) // IN: Frequency in Hz.
+@@ -3154,7 +3202,6 @@ HostIF_SetFastClockRate(unsigned int rate) // IN: Frequency in Hz.
}
} else {
if (linuxState.fastClockThread) {
- force_sig(SIGKILL, linuxState.fastClockThread);
-+ send_sig(SIGKILL, linuxState.fastClockThread, 1);
kthread_stop(linuxState.fastClockThread);
linuxState.fastClockThread = NULL;
+@@ -3200,7 +3243,12 @@
+
+ ASSERT(handle);
+
+- if (!access_ok(VERIFY_WRITE, p, size)) {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
++ if (!access_ok(VERIFY_WRITE, p, size))
++#else
++ if (!access_ok(p, size))
++#endif
++ {
+ printk(KERN_ERR "%s: Couldn't verify write to uva 0x%p with size %"
+ FMTSZ"u\n", __func__, p, size);
+