summarylogtreecommitdiffstats
path: root/wsjtx.patch
diff options
context:
space:
mode:
authorNeal Miller2018-06-07 20:00:48 -0500
committerNeal Miller2018-06-07 20:00:48 -0500
commitc4b26ff2c059439073903887cc19edf31005a025 (patch)
tree4ed6a7a409add63155b2aae199a6840cb7011b19 /wsjtx.patch
downloadaur-c4b26ff2c059439073903887cc19edf31005a025.tar.gz
Initial release of wsjtx (git version) on the AUR
Diffstat (limited to 'wsjtx.patch')
-rw-r--r--wsjtx.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/wsjtx.patch b/wsjtx.patch
new file mode 100644
index 000000000000..c55d1428b8e0
--- /dev/null
+++ b/wsjtx.patch
@@ -0,0 +1,23 @@
+diff -ur /CMakeLists.txt /CMakeLists.txt
+--- /CMakeLists.txt 2018-05-31 02:29:47.000000000 +0200
++++ /CMakeLists.txt 2018-06-03 09:34:15.109877528 +0200
+@@ -1343,7 +1343,8 @@
+ )
+ endif ()
+ endif ()
+-qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
++find_package(Qt5SerialPort)
++target_link_libraries (wsjtx Qt5::SerialPort)
+
+ # make a library for WSJT-X UDP servers
+ # add_library (wsjtx_udp SHARED ${UDP_library_CXXSRCS})
+@@ -1364,7 +1365,8 @@
+ )
+ target_compile_definitions (wsjtx_udp-static PUBLIC UDP_STATIC_DEFINE)
+ #qt5_use_modules (wsjtx_udp Network)
+-qt5_use_modules (wsjtx_udp-static Network Gui)
++target_link_libraries(wsjtx_udp-static Qt5::Network Qt5::Gui)
++
+ generate_export_header (wsjtx_udp-static BASE_NAME udp)
+
+ add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})