summarylogtreecommitdiffstats
path: root/xen.install
diff options
context:
space:
mode:
authorJanne Heß2017-01-12 18:16:55 +0100
committerJanne Heß2017-01-12 23:50:19 +0100
commit68c6c51b915780c891fc38ae82fcc8b44fb05a65 (patch)
treea0d44078a7929c0774fc616ef8c9f76927c70c4c /xen.install
parent035aa6e93208e6806d6ff0a38dcae88b1baab360 (diff)
downloadaur-68c6c51b915780c891fc38ae82fcc8b44fb05a65.tar.gz
Update to 4.9 and fixup
- Reformat PKGBUILD - Put all version numbers in the PKGBUILD together - Verify Xen with PGP - Remove obsolete patches - Add XSA 203 - Add XSA 204 - Add debug output while building - Run systemd-tmpfiles after installation - Add gitignore
Diffstat (limited to 'xen.install')
-rw-r--r--xen.install42
1 files changed, 22 insertions, 20 deletions
diff --git a/xen.install b/xen.install
index a15206874e8a..e7582d4e0b23 100644
--- a/xen.install
+++ b/xen.install
@@ -1,5 +1,5 @@
install_msg() {
- cat << __EOF__
+ cat << __EOF__
===> IMPORTANT NOTICES:
In order to complete the installation, and enable Xen,
@@ -31,41 +31,43 @@ __EOF__
}
upgrade_msg() {
- cat << __EOF__
-Xen 4.7
+ cat << __EOF__
+Xen 4.8
Release notes
-http://wiki.xen.org/wiki/Xen_Project_4.7_Release_Notes
+http://wiki.xen.org/wiki/Xen_Project_4.8_Release_Notes
Feature list
-http://wiki.xen.org/wiki/Xen_Project_4.7_Feature_List
+http://wiki.xen.org/wiki/Xen_Project_4.8_Feature_List
__EOF__
}
post_install() {
- install_msg
- upgrade_msg
+ install_msg
+ upgrade_msg
+ systemd-tmpfiles --create
}
post_upgrade() {
- upgrade_msg
+ upgrade_msg
+ systemd-tmpfiles --create
}
pre_remove() {
- systemctl stop xendomains.service
- systemctl stop xen-watchdog.service
- systemctl stop xenconsoled.service
- systemctl stop xen-init-dom0.service
- systemctl stop xen-qemu-dom0-disk-backend.service
-
- systemctl disable xendomains.service
- systemctl disable xen-watchdog.service
- systemctl disable xenconsoled.service
- systemctl disable xen-init-dom0.service
- systemctl disable xen-qemu-dom0-disk-backend.service
+ systemctl stop xendomains.service
+ systemctl stop xen-watchdog.service
+ systemctl stop xenconsoled.service
+ systemctl stop xen-init-dom0.service
+ systemctl stop xen-qemu-dom0-disk-backend.service
+
+ systemctl disable xendomains.service
+ systemctl disable xen-watchdog.service
+ systemctl disable xenconsoled.service
+ systemctl disable xen-init-dom0.service
+ systemctl disable xen-qemu-dom0-disk-backend.service
}
post_remove() {
- cat << __EOF__
+ cat << __EOF__
===> IMPORTANT NOTICE:
In order to finish removing Xen, you will need to modify