summarylogtreecommitdiffstats
path: root/.justfile
diff options
context:
space:
mode:
Diffstat (limited to '.justfile')
-rw-r--r--.justfile15
1 files changed, 15 insertions, 0 deletions
diff --git a/.justfile b/.justfile
new file mode 100644
index 000000000000..e460829e8323
--- /dev/null
+++ b/.justfile
@@ -0,0 +1,15 @@
+default:
+ just -l
+
+build: clean remove-pkgsum
+ makepkg
+
+clean:
+ rm -rf pkg src kickoff-*.zst kickoff-*.tar.gz
+
+remove-pkgsum:
+ sed -i -e "s/sha512sums=.*/sha512sums=('SKIP')/" PKGBUILD
+
+pkgsum: remove-pkgsum
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO