summarylogtreecommitdiffstats
path: root/.pre-commit
diff options
context:
space:
mode:
Diffstat (limited to '.pre-commit')
-rwxr-xr-x.pre-commit13
1 files changed, 13 insertions, 0 deletions
diff --git a/.pre-commit b/.pre-commit
new file mode 100755
index 000000000000..3b532023a662
--- /dev/null
+++ b/.pre-commit
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+# fix environment of githooks
+unset GIT_DIR
+# if PKGBUILD has been altered, update .SRCINFO
+for path in $(git diff --name-only --cached --diff-filter=AM); do
+ if [[ "${path}" =~ .*PKGBUILD$ ]]; then
+ echo -e "\e[01;32m *** Generating and adding .SRCINFO for ${path} ***\e[00m"
+ (makepkg --printsrcinfo > "${PWD}"/.SRCINFO) || exit 1
+ git update-index
+ git add "${PWD}"/.SRCINFO
+ fi
+done