summarylogtreecommitdiffstats
path: root/0001-update-odin-to-use-llvm-12.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-update-odin-to-use-llvm-12.patch')
-rw-r--r--0001-update-odin-to-use-llvm-12.patch84
1 files changed, 0 insertions, 84 deletions
diff --git a/0001-update-odin-to-use-llvm-12.patch b/0001-update-odin-to-use-llvm-12.patch
deleted file mode 100644
index 7d64116ed609..000000000000
--- a/0001-update-odin-to-use-llvm-12.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 45705c2ccdfe4af2a1cf6b238525111c0c84693f Mon Sep 17 00:00:00 2001
-From: pyxel <imhxnna@gmail.com>
-Date: Mon, 1 Nov 2021 00:32:54 -0400
-Subject: [PATCH] update odin to use llvm 12
-
----
- Makefile | 61 +++++++++++++++++++++++++++++---------------------------
- 1 file changed, 32 insertions(+), 29 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 23fb7be6..15d00655 100644
---- a/Makefile
-+++ b/Makefile
-@@ -7,35 +7,38 @@ CC=clang
-
- OS=$(shell uname)
-
--ifeq ($(OS), Darwin)
-- LLVM_CONFIG=llvm-config
-- ifneq ($(shell llvm-config --version | grep '^11\.'),)
-- LLVM_CONFIG=llvm-config
-- else
-- $(error "Requirement: llvm-config must be version 11")
-- endif
--
-- LDFLAGS:=$(LDFLAGS) -liconv
-- CFLAGS:=$(CFLAGS) $(shell $(LLVM_CONFIG) --cxxflags --ldflags)
-- LDFLAGS:=$(LDFLAGS) -lLLVM-C
--endif
--ifeq ($(OS), Linux)
-- LLVM_CONFIG=llvm-config-11
-- ifneq ($(shell which llvm-config-11 2>/dev/null),)
-- LLVM_CONFIG=llvm-config-11
-- else ifneq ($(shell which llvm-config-11-64 2>/dev/null),)
-- LLVM_CONFIG=llvm-config-11-64
-- else
-- ifneq ($(shell llvm-config --version | grep '^11\.'),)
-- LLVM_CONFIG=llvm-config
-- else
-- $(error "Requirement: llvm-config must be version 11")
-- endif
-- endif
--
-- CFLAGS:=$(CFLAGS) $(shell $(LLVM_CONFIG) --cxxflags --ldflags)
-- LDFLAGS:=$(LDFLAGS) $(shell $(LLVM_CONFIG) --libs core native --system-libs)
--endif
-+#ifeq ($(OS), Darwin)
-+# LLVM_CONFIG=llvm-config
-+# ifneq ($(shell llvm-config --version | grep '^11\.'),)
-+# LLVM_CONFIG=llvm-config
-+# else
-+# $(error "Requirement: llvm-config must be version 11")
-+# endif
-+#
-+# LDFLAGS:=$(LDFLAGS) -liconv
-+# CFLAGS:=$(CFLAGS) $(shell $(LLVM_CONFIG) --cxxflags --ldflags)
-+# LDFLAGS:=$(LDFLAGS) -lLLVM-C
-+#endif
-+#ifeq ($(OS), Linux)
-+# LLVM_CONFIG=llvm-config-11
-+# ifneq ($(shell which llvm-config-11 2>/dev/null),)
-+# LLVM_CONFIG=llvm-config-11
-+# else ifneq ($(shell which llvm-config-11-64 2>/dev/null),)
-+# LLVM_CONFIG=llvm-config-11-64
-+# else
-+# ifneq ($(shell llvm-config --version | grep '^11\.'),)
-+# LLVM_CONFIG=llvm-config
-+# else
-+# $(error "Requirement: llvm-config must be version 11")
-+# endif
-+# endif
-+#
-+# CFLAGS:=$(CFLAGS) $(shell $(LLVM_CONFIG) --cxxflags --ldflags)
-+# LDFLAGS:=$(LDFLAGS) $(shell $(LLVM_CONFIG) --libs core native --system-libs)
-+#endif
-+
-+CFLAGS:=$(CFLAGS) $(shell llvm-config --cxxflags)
-+LDFLAGS:=$(LDFLAGS) $(shell llvm-config --libs --ldflags) -lz -ltinfo
-
- all: debug demo
-
---
-2.33.1
-