summarylogtreecommitdiffstats
path: root/0002-makefile-32bit-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-makefile-32bit-compile.patch')
-rw-r--r--0002-makefile-32bit-compile.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/0002-makefile-32bit-compile.patch b/0002-makefile-32bit-compile.patch
new file mode 100644
index 000000000000..2f4c78130bbe
--- /dev/null
+++ b/0002-makefile-32bit-compile.patch
@@ -0,0 +1,16 @@
+diff -pNaru5 a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2022-12-25 22:17:35.764513705 -0500
++++ b/src/Makefile 2022-12-25 22:18:08.694755252 -0500
+@@ -35,11 +35,11 @@ BINDIR = /usr/bin
+ LIBDIR = /usr/lib
+ MANDIR = /usr/share/man/man1
+ MANFILE = p2c.man.inst
+
+ # Compiler options
+-CC = cc # you may wish to use gcc here instead
++CC = cc -m32 # you may wish to use gcc here instead
+ OPT = # -O # uncomment this for optimization
+ DEB = # -g # uncomment this for debugging
+ DEFS = -DTEST_MALLOC # place other -D types of things here # TDS 2015nov18
+ CFLAGS = $(OPT) $(DEB) $(DEFS)
+ LFLAGS =