summarylogtreecommitdiffstats
path: root/0004-glfw.patch
diff options
context:
space:
mode:
Diffstat (limited to '0004-glfw.patch')
-rw-r--r--0004-glfw.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/0004-glfw.patch b/0004-glfw.patch
new file mode 100644
index 000000000000..90070a15188b
--- /dev/null
+++ b/0004-glfw.patch
@@ -0,0 +1,28 @@
+From be9e10a37ac78e8f3aee57d65694c0eebc27b90c Mon Sep 17 00:00:00 2001
+From: howetuft <howetuft@gmail.com>
+Date: Sat, 21 May 2022 18:16:28 +0200
+Subject: [PATCH 04/14] glfw
+
+---
+ samples/luxcoreui/CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
+index 8b74e0704..d2e823874 100644
+--- a/samples/luxcoreui/CMakeLists.txt
++++ b/samples/luxcoreui/CMakeLists.txt
+@@ -22,7 +22,10 @@
+ #
+ #############################################################################
+
+-add_subdirectory(deps/glfw-3.1.1)
++find_package(glfw3 REQUIRED)
++IF(NOT ${GLFW3_FOUND})
++ add_subdirectory(deps/glfw-3.1.1)
++ENDIF()
+ include_directories(deps/glfw-3.1.1/include)
+ include_directories(deps/nfd/include)
+
+--
+2.43.0
+