summarylogtreecommitdiffstats
path: root/0013-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch
diff options
context:
space:
mode:
Diffstat (limited to '0013-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch')
-rw-r--r--0013-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/0013-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch b/0013-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch
new file mode 100644
index 000000000000..42bde496d8b3
--- /dev/null
+++ b/0013-Fix-errors-due-to-disabled-exceptions-with-cpp_winrt.patch
@@ -0,0 +1,29 @@
+From 4c0319dc229bec434f0ac6df9eff6826d3d06f91 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sat, 17 Feb 2024 20:31:12 +0100
+Subject: [PATCH 13/17] Fix errors due to disabled exceptions with cpp_winrt
+ support
+
+The winrt headers use exceptions so code using them must be compiled
+with exceptions enabled.
+
+Change-Id: I216f65b260062ff2020f8a288ddda78c3e9fc3c9
+---
+ src/plugins/platforms/windows/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/plugins/platforms/windows/CMakeLists.txt b/src/plugins/platforms/windows/CMakeLists.txt
+index ea119bfb1e2..4cc9b87ced7 100644
+--- a/src/plugins/platforms/windows/CMakeLists.txt
++++ b/src/plugins/platforms/windows/CMakeLists.txt
+@@ -9,6 +9,7 @@ qt_internal_add_plugin(QWindowsIntegrationPlugin
+ OUTPUT_NAME qwindows
+ PLUGIN_TYPE platforms
+ DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES windows
++ EXCEPTIONS
+ SOURCES
+ main.cpp
+ qtwindowsglobal.h
+--
+2.44.0
+