summarylogtreecommitdiffstats
path: root/011-fix-building-with-recent-acpica.patch
diff options
context:
space:
mode:
Diffstat (limited to '011-fix-building-with-recent-acpica.patch')
-rw-r--r--011-fix-building-with-recent-acpica.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/011-fix-building-with-recent-acpica.patch b/011-fix-building-with-recent-acpica.patch
new file mode 100644
index 000000000000..df74bcd0aa5e
--- /dev/null
+++ b/011-fix-building-with-recent-acpica.patch
@@ -0,0 +1,33 @@
+--- a/src/VBox/Devices/Makefile.kmk.orig 2018-04-13 16:36:12 UTC
++++ b/src/VBox/Devices/Makefile.kmk
+@@ -828,7 +828,12 @@ if !defined(VBOX_ONLY_EXTPACKS) # Goes on almo
+
+ $$(VBoxDD_0_OUTDIR)/vboxaml.hex: $(PATH_SUB_CURRENT)/PC/vbox.dsl | $$(dir $$@)
+ $(call MSG_TOOL,iasl,VBoxDD,$<,$@)
++ $(QUIET)$(RM) -f $@ $@.tmp
+ $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $<
++ $(QUIET)$(MV) -f $@ $@.tmp
++ $(QUIET)$(SED) -e "s/vboxaml_aml_code/AmlCode/g" \
++ --output $@ $@.tmp
++ $(QUIET)$(RM) -f $@.tmp
+
+ vboxaml.hex:: $$(VBoxDD_0_OUTDIR)/vboxaml.hex
+
+@@ -838,6 +843,8 @@ if !defined(VBOX_ONLY_EXTPACKS) # Goes on almo
+ $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $<
+ $(QUIET)$(MV) -f $@ $@.tmp
+ $(QUIET)$(SED) -e "s/AmlCode/AmlCodeSsdtStandard/g" \
++ -e "s/__VBOXSSDT-STANDARD_HEX__/__VBOXSSDT_STANDARD_HEX__/g" \
++ -e "s/vboxssdt-standard_aml_code/AmlCodeSsdtStandard/g" \
+ --output $@ $@.tmp
+ $(QUIET)$(RM) -f $@.tmp
+
+@@ -853,6 +860,8 @@ if !defined(VBOX_ONLY_EXTPACKS) # Goes on almo
+ $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $@.pre1
+ $(QUIET)$(MV) -f $@ $@.tmp
+ $(QUIET)$(SED) -e "s/AmlCode/AmlCodeSsdtCpuHotPlug/g" \
++ -e "s/__VBOXSSDT-CPUHOTPLUG_HEX__/__VBOXSSDT_CPUHOTPLUG_HEX__/g" \
++ -e "s/vboxssdt-cpuhotplug_aml_code/AmlCodeSsdtCpuHotPlug/g" \
+ --output $@ $@.tmp
+ $(QUIET)$(RM) -f $@.tmp $@.pre $@.pre1
+